Closed Bug 275327 Opened 15 years ago Closed 15 years ago

RFE: Ability to Delete Search Engines

Categories

(Firefox :: Search, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 232272

People

(Reporter: blakesley, Assigned: p_ch)

Details

Currently there is no way to delete search engines from the search bar from
within Firefox.

I propose that pressing [shift]+[del] while an engine on the drop-down list is
selected should result in that engine being deleted (in the same way that a
searched for phrase can be deleted).

Also, I think there should be a "Remove search engines..." interface (accessible
from the drop-down list) for doing this (for those who are not aware of the
[shift]+[del] technique).

(Ideally, it would be nice if there was a built-in search engine manager within
Firefox for downloading & adding, removing, enabling and disabling individual
search engines, but that is another bug for the future.)

This is very important because (as I noted in bug 266227) the developers of
Firefox have decided to add many SEs by default which many people wouldn't ever
use (e.g.: the top two are exactly the same SE and two of them are for shopping
sites) and it is very difficult for users currently to replace them with SEs
that are more appropriate to themselves.

(BTW, is their a bug to discuss which SEs should be included by default?)
(In reply to comment #0)
> but that is another bug for the future

Actually, that's this same bug from the past: bug 232272 in general, bug 232272
comment 12 in particular.

*** This bug has been marked as a duplicate of 232272 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
I searched all comments for various phrases as I thought someone must have
submitted it (I meant to over a year ago) and it didn't come up with anything
unofortunately.

Anyway, I agree this is a sort of duplicate.  However, maybe this bug should be
kept to seperate off the "ability to delete search engines" (which is a bug that
needs fixing ASAP) from the more general long-term "Better management of search
engines for toolbar over the current add new engines system" (summary of bug
23227).    I don't know.
You need to log in before you can comment on or make changes to this bug.