Shockwave site that crashes mozilla http://www.z100.com/source/hpsn/britney/index.html

VERIFIED DUPLICATE of bug 30372

Status

()

Core
Plug-ins
P3
critical
VERIFIED DUPLICATE of bug 30372
19 years ago
19 years ago

People

(Reporter: Johan, Assigned: av (gone))

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Yeah I know it's a lame site but hey mozilla crashes

Comment 1

19 years ago
have a stackstrace or talback incident id?

plugin component -> av
Assignee: chofmann → av
Summary: Shockwave site that crashes mozilla → Shockwave site that crashes mozilla

Updated

19 years ago
Keywords: crash
Summary: Shockwave site that crashes mozilla → Shockwave site that crashes mozilla http://www.z100.com/source/hpsn/britney/index.html

Updated

19 years ago
Severity: normal → critical

Comment 2

19 years ago
Ok, here is more info.  bucht@hem.utfors.se has sent in a 
talkback crash with a stack that looks like this...

2000022821 build

might not be plugins.  adding erik, troy, jbetak to cc list.

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/gfx/src/windows/nsFontMetric
sWin.cpp

maybe erik can/should take this bug?

Incident ID 6348909 
nsFontMetricsWin::SameAsPreviousMap 
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsFontMetricsWin.cpp, line 1060] 
nsFontMetricsWin::FindGlobalFont 
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsFontMetricsWin.cpp, line 1101] 
nsFontMetricsWin::FindFont 
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsFontMetricsWin.cpp, line 1650] 
GKGFXWIN.DLL + 0x12da8 (0x60a32da8) 
nsDrawingSurfaceWin::AddRef 
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsDrawingSurfaceWin.cpp, line 163] 
0x85561055 

Comment 3

19 years ago
I tried it in a recent DEBUG build, and it's crashing somewhere else:

nsJSProtocolHandler::NewChannel(nsJSProtocolHandler * const 0x02d0f670, const 
char * 0x01ac625c ??_C@_04JMJF@load?$AA@, nsIURI * 0x02d0fb30, nsILoadGroup * 
0x00000000, nsIInterfaceRequestor * 0x00000000, unsigned int 0, nsIURI * 
0x00000000, unsigned int 0, unsigned int 0, nsIChannel * * 0x0012be28) line 207 
+ 36 bytes
nsIOService::NewChannelFromURI(nsIOService * const 0x0142cb50, const char * 
0x01ac625c ??_C@_04JMJF@load?$AA@, nsIURI * 0x02d0fb30, nsILoadGroup * 
0x00000000, nsIInterfaceRequestor * 0x00000000, unsigned int 0, nsIURI * 
0x00000000, unsigned int 0, unsigned int 0, nsIChannel * * 0x0012be28) line 241 
+ 59 bytes
NS_OpenURI(nsIChannel * * 0x0012be58, nsIURI * 0x02d0fb30, nsILoadGroup * 
0x00000000, nsIInterfaceRequestor * 0x00000000, unsigned int 0, unsigned int 0, 
unsigned int 0) line 79 + 58 bytes
NS_OpenURI(nsIStreamListener * 0x02d0fb80, nsISupports * 0x00000000, nsIURI * 
0x02d0fb30, nsILoadGroup * 0x00000000) line 117 + 25 bytes
nsPluginHostImpl::NewPluginURLStream(nsPluginHostImpl * const 0x01434b00, const 
nsString & {...}, nsIPluginInstance * 0x02d0b590, nsIPluginStreamListener * 
0x02d0fc00) line 2312 + 17 bytes
nsPluginHostImpl::GetURL(nsPluginHostImpl * const 0x01434b00, nsISupports * 
0x02d0b590, const char * 0x6c02d4b4, const char * 0x00000000, 
nsIPluginStreamListener * 0x02d0fc00, const char * 0x00000000, const char * 
0x00000000, int 0) line 1180 + 30 bytes
ns4xPlugin::_geturl(_NPP * 0x02d0b5a0, const char * 0x6c02d4b4, const char * 
0x00000000) line 470 + 39 bytes
NP32DSW! 6c001802()
ns4xPluginInstance::InitializePlugin(nsIPluginInstancePeer * 0x02d0b530) line 
449 + 40 bytes
ns4xPluginInstance::Initialize(ns4xPluginInstance * const 0x02d0b590, 
nsIPluginInstancePeer * 0x02d0b530) line 362
nsPluginHostImpl::SetUpPluginInstance(nsPluginHostImpl * const 0x01434b04, const 
char * 0x014ff240, nsIURI * 0x02d0ba50, nsIPluginInstanceOwner * 0x02d0bb30) 
line 1736
nsPluginHostImpl::InstantiateEmbededPlugin(nsPluginHostImpl * const 0x01434b04, 
const char * 0x014ff240, nsIURI * 0x02d0ba50, nsIPluginInstanceOwner * 
0x02d0bb30) line 1460 + 24 bytes
nsObjectFrame::InstantiatePlugin(nsIPresContext * 0x02cb9070, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, nsIPluginHost * 
0x01434b04, const char * 0x014ff240, nsIURI * 0x02d0ba50) line 965
nsObjectFrame::Reflow(nsObjectFrame * const 0x021e6b34, nsIPresContext * 
0x02cb9070, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 862 + 43 bytes
nsLineLayout::ReflowFrame(nsIFrame * 0x021e6b34, nsIFrame * * 0x0012d5f8, 
unsigned int & 0, nsHTMLReflowMetrics * 0x00000000, int & 0) line 992

Comment 4

19 years ago
I wasn't able to reproduce the crash with the given stack trace. I don't have 
the shockwave plugin.

Comment 5

19 years ago
I think you need the shockwave plugin in order to reproduce the bug. I got the
plugin while in Nav4, and then started Moz.
(Reporter)

Comment 6

19 years ago
I havn't got shockwave plugin for netscape just for ie5.

/Johan Bucht

Comment 7

19 years ago
Updating QA Contact.
Component: other → Plug-ins
QA Contact: leger → shrir

Comment 8

19 years ago
I see the crash on Win NT on today's commercial beta1 bits. (2000032306)
Stack trace from TALKBACK:

Trigger Type:  Program Crash
Trigger Reason:  Access violation
Thread ID: 
103
Call Stack:    (Signature = nsJSProtocolHandler::NewChannel 115c3304)
     nsJSProtocolHandler::NewChannel 
[d:\builds\seamonkey\mozilla\dom\src\jsurl\nsJSProtocolHandler.cpp, line 208]
     nsIOService::NewChannelFromURI 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsIOService.cpp, line 242]
     NS_OpenURI [..\..\..\dist\include\nsNetUtil.h, line 80]
     NS_OpenURI [..\..\..\dist\include\nsNetUtil.h, line 118]
     nsPluginHostImpl::NewPluginURLStream 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp, line 
2339]
     nsPluginHostImpl::GetURL 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp, line 
1182]
     ns4xPlugin::_geturl 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\ns4xPlugin.cpp, line 474]
     np32dsw.dll + 0x1802 (0x6c001802)  
     ns4xPluginInstance::InitializePlugin 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\ns4xPluginInstance.cpp, line 
452]
     ns4xPluginInstance::Initialize 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\ns4xPluginInstance.cpp, line 
362]
     nsPluginHostImpl::SetUpPluginInstance 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp, line 
1736]
     nsPluginHostImpl::InstantiateEmbededPlugin 
[d:\builds\seamonkey\mozilla\modules\plugin\nglsrc\nsPluginHostImpl.cpp, line 
1462]
     nsObjectFrame::InstantiatePlugin 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsObjectFrame.cpp, line 965]
     nsObjectFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsObjectFrame.cpp, line 863]
     nsLineLayout::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 992]
     nsBlockFrame::ReflowInlineFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 4023]
     nsBlockFrame::DoReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3907]
     nsBlockFrame::DoReflowInlineFramesAuto 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3848]
     nsBlockFrame::ReflowInlineFrames 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3794]
     nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2970]
     nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2671]
     nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1590]
     nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line 
450]
     nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3551]
     nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2868]
     nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2671]
     nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1590]
     nsBlockReflowContext::ReflowBlock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line 
450]
     nsBlockFrame::ReflowBlockFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3551]
     nsBlockFrame::ReflowLine 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2868]
     nsBlockFrame::ReflowDirtyLines 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2671]
     nsBlockFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1590]
     nsAreaFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAreaFrame.cpp, line 277]
     nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
669]
     RootFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 334]
     nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
669]
     nsScrollPortFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsScrollPortFrame.cpp, line 
481]
     nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
669]
     nsGfxScrollFrameInner::ReflowFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
1366]
     nsGfxScrollFrameInner::ReflowScrollArea 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
1428]
     nsGfxScrollFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
582]
     nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
669]
     ViewportFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 531]
     nsHTMLReflowCommand::Dispatch 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 
145]
     PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2054]
     PresShell::ExitReflowLock 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 903]
     PresShell::ContentAppended 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2626]
     nsDocument::ContentAppended 
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 1591]
     nsHTMLDocument::ContentAppended 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line 
1127]
     HTMLContentSink::NotifyAppend 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp, 
line 3987]
     SinkContext::FlushTags 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp, 
line 1924]
     HTMLContentSink::CloseBody 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLContentSink.cpp, 
line 2715]
     CNavDTD::CloseBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 2676]
     CNavDTD::CloseContainer 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 2985]
     CNavDTD::CloseContainersTo 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3045]
     CNavDTD::CloseContainersTo 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3240]
     CNavDTD::DidBuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 563]
     nsParser::DidBuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 723]
     nsParser::ResumeParse 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1220]
     nsParser::OnStopRequest 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1645]
(Assignee)

Comment 9

19 years ago
Looks like a dup for 30372. The fix has been suggested there. Marking duplicate.

*** This bug has been marked as a duplicate of 30372 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
Verifying duplicate. Same stack trace.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.