improve scalable font handling on X

RESOLVED DUPLICATE of bug 74889

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 74889
18 years ago
13 years ago

People

(Reporter: Erik van der Poel, Assigned: kill this account)

Tracking

({fonts, helpwanted})

Trunk
Future
x86
Linux
fonts, helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The following font properties might tell us whether the user is using a good
scaler that gives beautiful results. In that case, we might want to scale,
rather than using a bitmap font that is too large or too small.

  FONT_TYPE and RASTERIZER_NAME
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Reporter)

Comment 1

18 years ago
From: Juliusz Chroboczek <jec@dcs.ed.ac.uk>
To: fonts@XFree86.Org

The TrueType renderer known as ``xfsft'' generates FONT_TYPE
(``TrueType'').  It currently does not generate ``RASTERIZER_NAME'',
but I can add this if you wish.  As far as I know, no other renderer
currently generates these properties.
(Reporter)

Comment 2

18 years ago
From: Keith Packard <keithp@suse.com>
To: fonts@XFree86.Org

XListFontsWithInfo would nominally be cheaper than XLoadQueryFont except
that XListFontsWithInfo returns bounding box information for the glyphs
in the font.  The only way to generate that accurately from scalable
fonts is to rasterize the entire font and see where the pixels fall.

So, if you think you might want to use a particular font, you should
just open it and throw it away if you don't like the rasterizer it used.
(this bug broke out of bug 13072)
Summary: improve scalable font handling on X → improve scalable font handling on X {font}
Keywords: fonts
Summary: improve scalable font handling on X {font} → improve scalable font handling on X
(Reporter)

Comment 4

18 years ago
Prioritizing my bugs. This one is now M19.
Target Milestone: M15 → M19

Comment 5

17 years ago
reassign this bug to bstell and mark it as M25. Add helpwanted keyword
Assignee: erik → bstell
Status: ASSIGNED → NEW
Keywords: helpwanted
Target Milestone: M19 → M25
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Assignee)

Comment 6

17 years ago
I found this bit:

http://www.xfree86.org/archives/fonts/2000-Feb/0012.shtml
>     There's a trick for this that works well with commonly available X 
>     servers, though it probably has no theoretical justification. 
>     Scaleable fonts returned by XListFonts (0 point and pixel size) that 
>     are just scaled bitmaps have non-0 X and Y resolution fields, while 
>     true scaleable fonts have 0 in those fields. 
> 
>     The GTK+ font selector uses this technique, and I haven't heard 
>     of any complaints about it failing there. 
> 
>     Regards, 
>                                             Owen 
(Assignee)

Comment 7

17 years ago
http://www.XFree86.org/FAQ/#BitmapFontScaling
> Q.E1- How do I get the server to scale vector fonts, but not bitmap fonts?
> 
> In standard X11R6 (and later), in addition to the fonts in "scalable" formats
>  (i.e. Type1, Speedo), bitmap fonts are scaled. This can have the undesirable
> effect of scaling a bitmap font, even though a Type1 font is available (if 
> the bitmap font is listed first in the path). 
> 
> With the 3.2 and later releases of XFree86, you can add the text :unscaled to 
> the end of any directory in the font path to turn off scaling of the bitmap 
> fonts in that directory. This works in both the XF86Config file and the font 
> server's config file. 
(Assignee)

Comment 8

17 years ago
fix for bug 74889 include test for bitmap scaled font

*** This bug has been marked as a duplicate of 74889 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.