If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash on startup at profile selection

VERIFIED DUPLICATE of bug 27064

Status

()

Core
Layout
P3
critical
VERIFIED DUPLICATE of bug 27064
18 years ago
18 years ago

People

(Reporter: Eric Lesage, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bug Helper:
BuildID:    Unavailable (make -f client.mk done on Sat Feb 12, 2000)
When starting mozilla-bin with ./mozilla, the "Select User Profile" windows gets
to display (it is empty at this point) and then the
application crashes.
Reproducible: Always
Steps to Reproduce:
Start mozilla in dist/bin with ./mozilla
It eventually segfaults.
Actual Results:  .//run-mozilla.sh: line 29: 24660 Segmentation fault      $prog
${1 "$@"}
Expected Results:  Mozilla should have allowed me to create or select a profile.
I have just done a make -f client.mk a few hours ago (sat feb 12), but this
problem has been there for at least a week; I'm saying that because I had not
checked out a tree for a few weeks before that, so it may be longer. Note that I
had never seen this step before (Select User Profile).

The .mozilla/registry file is created before the crash.

I'm using Linux 2.2.14, gcc 2.95.1, binutils 2.9.1.0.19a; mozilla used to work
here before.

I'll be attaching the standard output. Unfortunately running mozilla -g doesn't
get as far (signal ? received).
(Reporter)

Comment 1

18 years ago
Created attachment 5207 [details]
Standard output/error before crash

Comment 2

18 years ago
Please provide a stack trace from your core file.  The info included doesn't 
clarify whether profile manager is actually at fault.
(Reporter)

Comment 3

18 years ago
Created attachment 5358 [details]
Gdb session and backtrace
(Reporter)

Comment 4

18 years ago
Ok, I just got myself a new gdb from Redhat's ftp server with support for
threads (the latest vanilla gdb doesn't have it... apparently gdb 5.0 is due in
a few weeks). So now I can go all the way to the place where it segfaults. It
might indeed not be a profile manager bug anymore, but I'm not familiar enough
with the internals of mozilla to judge that.

I also added a line to run-mozilla to output the limits on my system.
It might be useful as well for you to know I use gtk+ version 1.2.4
(libgtk-1.2.so.0.2.2).

Comment 5

18 years ago
nsGCCache::GetGCFromDW looks like Pavlov, reassigning.  Is layout the correct
component for GC stuff?
Assignee: selmer → pavlov
Component: Profile Manager BackEnd → Layout
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

18 years ago
upgrade binutils.

*** This bug has been marked as a duplicate of 27064 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
agree
(Reporter)

Comment 8

18 years ago
Ok, I upgraded my binutils to 2.9.5.0.27; everything works again. Perhaps this
should be noted in the requirements sections of the build instructions? In any
case, thanks to everyone, and sorry the bug turned out to be a duplicate. 
You need to log in before you can comment on or make changes to this bug.