Closed Bug 275629 Opened 17 years ago Closed 15 years ago

incorrect text in extension installation prompt

Categories

(Toolkit :: Add-ons Manager, defect)

1.8 Branch
defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: mikerobi, Assigned: robert.strong.bugs)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

While installing an extension from my hard drive the installation window says "a
web site is requesting permission to install the following items"
confirming, -> Firefox
Assignee: mscott → bugs
Status: UNCONFIRMED → NEW
Component: General → Extension/Theme Manager
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → Firefox
QA Contact: bugs
Hardware: PC → All
Summary: incorrent text in extension installation prompt → incorrect text in extension installation prompt
By the time the user gets to this dialog they have either:

  - done a local install from disk
  - received an install request from a whitelisted site

Seems to me that the string is globally incorrect, and should be changed to:

itemWarningIntroMultiple=You have asked to install the following %S items:

itemWarningIntroSingle=You have asked to install the following item:

Attached patch patchSplinter Review
beltzner, I agree this is better but wanted to point out that there is also the case where a web site could initiate an install that could display the dialog as long as the site is already added to the whitelist. I personally think this case is too edgey to bother with in regards to this text since the vast majority of the time an install will be user initiated whether it be from a web page or a local install.
Assignee: bugs → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #225752 - Flags: ui-review?(beltzner)
Attachment #225752 - Flags: review?(benjamin)
Attachment #225752 - Flags: review?(benjamin) → review?(mconnor)
Comment on attachment 225752 [details] [diff] [review]
patch

Yeah, I considered that edge case, and came to the same conclusion. :)
Attachment #225752 - Flags: ui-review?(beltzner) → ui-review+
Version: unspecified → 2.0 Branch
Attachment #225752 - Flags: review?(mconnor) → review?(benjamin)
Whiteboard: [needs review]
Attachment #225752 - Flags: review?(benjamin) → review+
Checked in to trunk
Whiteboard: [needs review]
Attachment #225752 - Flags: approval1.8.1?
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Attachment #225752 - Flags: approval1.8.1? → approval1.8.1+
Checked in to MOZILLA_1_8_BRANCH for Firefox 2.0
Keywords: fixed1.8.1
QA Contact: bugs → extension.manager
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.