Templatise 'voteremovedmail' email

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Email Notifications
P2
enhancement
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Emmanuel Seyman)

Tracking

2.19.1
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The 'voterremovedmail' param should instead be a template.

See bug 84876 for hints and possible code for this.
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → email-notifications
QA Contact: mattyt-bugzilla → default-qa
(Reporter)

Updated

13 years ago
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.22
(Reporter)

Updated

13 years ago
Assignee: email-notifications → eseyman
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

13 years ago
If the contents of the mail are in a template file, won't the mails sent out be
in the language the vote-remover is viewing bugzilla in?
Won't this result in mails that they might not be able to read because it uses a
language they don't understand?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> If the contents of the mail are in a template file, won't the mails sent out be
> in the language the vote-remover is viewing bugzilla in?
> Won't this result in mails that they might not be able to read because it uses a
> language they don't understand?

  Yes, that would be a problem... I suppose you'll have to figure out the best
way to solve it. Viewers should get mail in the language *they* prefer, not mail
in the language the sender prefers.

  Perhaps a new Setting for Preferred Language would do this.
(Assignee)

Comment 4

13 years ago
(In reply to comment #3)
> Perhaps a new Setting for Preferred Language would do this.

I was thinking of adding a field to the profiles tables to keep track of the
language the user viewed Bugzilla in the last time he was logged in.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> I was thinking of adding a field to the profiles tables to keep track of the
> language the user viewed Bugzilla in the last time he was logged in.

  I think a Setting would be better. That's the mechanism we already have available.
(Assignee)

Comment 6

13 years ago
(In reply to comment #5)
> I think a Setting would be better.

I suppose this is the User Preferences page.
So we'ld have something in the "Global Options" part of the "Email Settings" tab
that allows the user to choose one of the languages for which we have templates
installed.

Comment 7

13 years ago
The trunk is now frozen to prepare Bugzilla 2.22. Enhancement bugs are retargetted to 2.24.
Target Milestone: Bugzilla 2.22 → Bugzilla 2.24
(Reporter)

Comment 8

12 years ago
*** Bug 306775 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

12 years ago
Created attachment 215274 [details] [diff] [review]
Move the param to a template file
Attachment #215274 - Flags: review?(LpSolit)
(Assignee)

Updated

12 years ago
Summary: Templatise 'voterremovedmail' email → Templatise 'voteremovedmail' email

Comment 10

12 years ago
Comment on attachment 215274 [details] [diff] [review]
Move the param to a template file

>+++ ./Bugzilla/Bug.pm	2006-03-15 18:24:29.000000000 +0100

>-            $substs{"to"} = $name . Param('emailsuffix');
>+                'to' => $name,

Param('emailsuffix') has been accidently removed. It must be set back on checkin.


+            $template->process("email/voteremoved.txt.tmpl", $vars, \$msg);

Nit: votes-removed.txt.tmpl would probably be a better template name.


Anyway, the patch works correctly. So r=LpSolit
Attachment #215274 - Flags: review?(LpSolit) → review+

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+

Comment 11

12 years ago
Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.115; previous revision: 1.114
done
Checking in Bugzilla/Config/MTA.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Config/MTA.pm,v  <--  MTA.pm
new revision: 1.8; previous revision: 1.7
done
Checking in template/en/default/admin/params/mta.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/params/mta.html.tmpl,v  <--  mta.html.tmpl
new revision: 1.4; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/email/votes-removed.txt.tmpl,v
done
Checking in template/en/default/email/votes-removed.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/email/votes-removed.txt.tmpl,v  <--  votes-removed.txt.tmpl
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.