asus.com: Javascript links do not work; no color change/menu on mouse-over.

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: wb1ccp, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the page at http://usa.asus.com/index.htm , all javascript links are totally
ignored.  The background behind the link text normally changes color on mouse -
over but not with Mozilla. No text appears in the Status Bar on mouse - over,
nor does the mouse pointer change to the finger icon.  This is true with both
FireFox 1.0 and Mozilla 1.7.5 .  Some text links near the bottom of the page
work correctly.  All items on the page appear to function correctly in MS-IE6
and Opera.

Reproducible: Always

Steps to Reproduce:
1.Go to http://usa.asus.com/index.htm
2.Try to click any of the links at top of page: About ASUS, Products, Support,
etc. or any item in the "Hot Products" box at left.
3. 
Actual Results:  
Nothing.

Expected Results:  
On mouse - over, mouse pointer should change to finger, button or drop-down menu
should appear behind text, link target text should appear in the Status Bar. 
Clicking link should open the target URL.

I have noticed similar problems with several pages, this one is a good example
which does not require a login.
The flash is above the menu. They set the flash to z-index:1 but I can't find
that they set the menu above it. It seems to work if I set "z-index:-1" for the
flash but I don't know why this should work in IE.

<div id="Layer1" style="position:absolute; width:200px; height:115px; z-index:1;
left: 4px; top: 3px;">                            
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
width="750" height="480" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="/event/happy holidays 2005/x-mas.swf" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#000000" />
<embed src="/event/happy holidays 2005/x-mas.swf" quality="high"
wmode="transparent" bgcolor="#000000" width="750" height="480" align="middle"
allowscriptaccess="sameDomain" type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer" />                   
        
</object>
</div>

-> Layout but this should be tech evangelism
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk
-> invalid

This also doesn't work with IE5.01, Opera6.01 because the flash is above the menu
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.