Chinese Characters missing in option/select tab (pull down mens) and buttons

RESOLVED DUPLICATE of bug 278255

Status

RESOLVED DUPLICATE of bug 278255
14 years ago
14 years ago

People

(Reporter: j4nu5.n6, Assigned: mikepinkerton)

Tracking

unspecified
Camino0.9
PowerPC
All

Details

(URL)

(Reporter)

Description

14 years ago
Sometimes, some chinese characters are missing in the option/select tab which
forms a pull down menu, and in buttons.  The above url is an example of a web
page in apple taiwan site that is rendered incorrectly.

The same page works fine in Firefox 1.0.
This sounds/looks like a duplicate of bug 199751 (other than the part about
working in Fx 1.0).  There seem to be lots of places where the Mozilla code is
not displaying certain Chinese characters (perhaps related to the problem with
the font-reading code (bug 246527)).

Janus, are you reporting this against a Camino branch (0.8.2) or trunk/nightly
build (0.8+)?  What happens when you test in a recent trunk nightly of Firefox
or the Mozilla Suite?


(Assignee)

Updated

14 years ago
Target Milestone: --- → Camino0.9
(Reporter)

Comment 2

14 years ago
The Apple Taiwan Kownledge Base server is down today.  I can't verify it again
before posting.

However, as I recall, it works in Firefox 1.0 but not the official Camino 0.8.2
and the Camino trunk build of Dec 24-26, 2004.

I am not sure whether it is related to the <input> tag bug; nonetheless, I have
encoutered that bug as well.  If they are related, it tells that the bug affects
more than <input> tag.  On the other hand, I have never encountered that bug in
<textarea> tag.
Janus, can you find another URL or generate a testcase?  That URL has been down
for the last several days, and I wanted to see if perhaps this bug was the same
as  bug 278255 (see particularly bug 278255 comment 8).

(This is an odd bug, UNCO but on the 0.9 list....)
(Reporter)

Comment 4

14 years ago
Sure, just like this one:

http://www.oikos.com.tw/v4/temp/news.php

Both the pull down menu and the button on the left hand side under "&#35342;&#35542;&#21312;&#32317;&#30446;&#37636;
" can't be shown.

The text on the search button located on the lower right hand side on this page
in front of beige background is missing as well:
http://www.frostyplace.com/

So does the pull down menu located on the top right hand side of this page:
http://www.imacguru.com/index.php

So does the text on this page as well:
http://diary.yam.com/hercafe/mydiary/theskyofmonc
I didn't notice any problem at the imacguru site, but the others all exhibited
the same behavior as described in bug 278255 comment 8--they'll display properly
if you reset your Traditional Chinese font preferences to the fonts that the
Cocoa preferences UI in Camino (but not the Carbon in Gecko, which actually does
the rendering) thinks are missing, so this is a dupe.

*** This bug has been marked as a duplicate of 278255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.