Open Bug 276166 Opened 17 years ago Updated 5 months ago

Implement "Fit to window width" as in Opera 8.0 (no-horizontal-scrollbar mode)

Categories

(Core :: Layout, enhancement)

enhancement
Not set
normal

Tracking

()

REOPENED

People

(Reporter: bugzillamozilla, Unassigned)

References

Details

(Keywords: mobile, parity-opera-mini)

Basically, this feature changes image magnification, text zoom and reflow so
that the window can be resized, yet a horizontal scrollbar is not needed.

You can download the latest Opera beta (with this feature) from here:
http://fileforum.betanews.com/detail/Opera_for_Windows_without_Java/945720329/1

Prog.
Whiteboard: parity-opera
Severity: normal → enhancement
on Mac, Netscape 4.x, Safari and IE have the feature.
see Bug 232919.
(In reply to comment #1)
> on Mac, Netscape 4.x, Safari and IE have the feature.

No you don't. Opera's feature doesn't change the *window* width, it changes the
*content* width/magnification/reflow. Try it, you really should. It's a truely
innovative feature that's already implemented very very well.

Prog.

Oh, sorry.
Whiteboard: parity-opera → parity-opera DUPEME
I second this request. It would really be great on Tablet PCs in portrait mode. Most have 768 width in this mode, while websites are typically designed for at least 800, causing horizontal scrollbars everywhere. This is a feature that would be very tough to implement as an extension.
Will this EVER be implemented? Horizontal scrolling sucks and I have to use Opera for some pages because they are simply unreadable with Gecko engine. =/
*** Bug 351569 has been marked as a duplicate of this bug. ***
Doesn't this depend on bug 4821 (full zooming) ?
The feature being requested here is described as "Medium Screen Rendering" in the following page:
http://www.howtocreate.co.uk/operaStuff/renderingMode.html
This page may give everyone a better idea of what is involved in implementing the feature. It isn't just a straight scaling of all content, but some sort of smart algorithmic adjustment of the rendering of different elements. This would be a great feature for Firefox used on any non-standard screen sizes-- Tablet PCs, UMPCs, and also adaptations of Firefox for display on TVs, PDAs, etc. Opera is currently doing very well in this area in part because of features like this. 
Duplicate of this bug: 378073
UMPC users (eee pc users for example) would really need the fit to width feature!
I want it, too! I'm a Nokia Internet Tablet user, with an 800-pix wide screen, and this is a necessity for enlarging fonts for easy reading without having to scroll. The upcoming Nokia Tablet will be released without a "Fit Width to View" option, so Nokia says we should "request it upstream." 

For anyone tackling this, you might want to look at its history on the Nokia N800 and N810. (Some of it is discussed here: 
http://www.internettablettalk.com/forums/showthread.php?t=28322)
As implemented to date on the Nokia Tablets, there are some webpages that the function chokes on, so it needs to be activated judiciously by the user; but there are users (me included) who, for many primarily-text webpages, just can't do without it. Whether the Opera implementation is better, and doesn't force the browser to a crawl on some websites, I don't know.
This would probably help mobile/tablet devices considerably...
Flags: wanted-fennec1.0?
Keywords: mobile
Whiteboard: parity-opera DUPEME → parity-opera
Yes please, do it.

I don't use firefox on my netbook any more because of this lack.

Thanks
Duplicate of this bug: 493171
Can you not do it with a bit of Javascript to transform the page slightly? What extra work would be involved?
Flags: wanted-fennec1.0?
As the programmers will quickly rebut, not having fit-to-width is not a bug.

HOWEVER....

Please implement fit-to-width exactly as Opera has been doing for years and years!

Please examine their code, (or the results of their code).

Let me ask the programmers here a question or two.

Do you know why books have a standard width for their pages?
Do you know why newspapers have a standard column width?

The reason is simple.
It has been scientifically proven that it is easier to read a column of text if it is not exceedingly wide. There is an optimum column width for reading text.

Right now Firefox is NOT providing that width!
By implementing 'fit-to-width' as Opera implements it, users will be able to read columns far more comfortably than they now can.

Please DO IT!

TIA
guardemg-2@yahoo.ca: Technical comments or patches welcome; "Me too" comments are not (please silently Vote instead). Please keep that in mind - thanks!
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: parity-opera → [parity-presto opera]
If, as you say, this feature works for you, please describe how. I don't see any way to do what is asked in 58.0.2. Is this feature in an unreleased version? If so, which one?
Flags: needinfo?(jwatt)
(In reply to riley from comment #18)
> If, as you say, this feature works for you, please describe how.

I thought we do something like this in Firefox Mobile nowadays. Then again, there are no attached testcases or examples of pages that people are unhappy with our handling of mentioned in this bug for me to test. Can someone provide some that work in Opera Mini but not in Firefox Mobile?

It's also worth noting that the steps describing how to turn on "Medium Screen Rendering" here:

http://www.howtocreate.co.uk/operaStuff/renderingMode.html

presumably no longer work in desktop Opera. In my Mac install there's no 'View - Fit to width' menu item, and I don't see an Opera6.ini or Opera6Def.ini file in Opera Desktop any more (under "~/Library/Application Support/Opera").
Status: RESOLVED → REOPENED
Flags: needinfo?(jwatt)
Resolution: WORKSFORME → ---
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Whiteboard: [parity-presto opera]

FWIW, I've implemented this function as an userscript. https://greasyfork.org/en/scripts/16697-toggle-zoom

You need to log in before you can comment on or make changes to this bug.