text overlaps, draws text on top of other text for no good reason

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: reznet, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I first noticed when viewing source that rows of text would overlap.  The
correct text would be displayed, and in the same location, text from another
part of the file would be displayed.  This second text would also appear in its
correct spot, so the text was being drawn twice.  I then stumbled upon the error
while working with some very simple source, so I don't think this problem can be
attributed to bad markup.  I'm attaching a file which demonstrates this problem.
 When this file is viewed in IE6, the text does not overlap.  There are no
styles present, and no div tags.

It seems that the problem is related to two things: newlines in the source, and
text that doesn't fit in the viewable region.  This source has <PRE>'s, and
inside that code is a very long line of text.  This line does not all fit in the
window, so the scroll bar is drawn.  However, text from offscreen is rendered on
screen, on top of the visible text.  It also seems that this happens multiple
times, so that multiple offscreen lines are rendered on top of one onscreen file.

Reproducible: Sometimes

Steps to Reproduce:
1. Once you find a file that exhibits this problem, it is always reproducible.
2. But, not all files show this problem.
3. Attached is a file with this problem.
4. The problem will go away if I scroll the window to the right, and then back,
forcing a redraw.  When I do this, the text does not overlap.
5. The problem happens not at just one text size, but I noticed the problem
going away as the text size got very large or very small.

Actual Results:  
Text that should be hidden because it doesn't fit on the page (drawn ofscreen)
is rendered on top of text that should be visible.

Expected Results:  
Only displayed the text that fits within the visible region.

I verified that this problem still occurs in the nightly from the 28th, using a
new profile w/o extensions.
(Reporter)

Comment 1

14 years ago
Created attachment 169748 [details]
test case html with exhibits the problem.
(Reporter)

Comment 2

14 years ago
Created attachment 169749 [details]
screenshot showing overlapping text
(Reporter)

Comment 3

14 years ago
Created attachment 169750 [details]
screenshot showing problem going away as text is selected

as I drag to select the text on the line, the hightlited text is rendered
correctly, but the rest of the line continues to exhibit the problem.
(Reporter)

Comment 4

14 years ago
Created attachment 169751 [details]
screenshot showing problem returning as multiple lines are selected

as i select one line, it is rendered selected and without the overlap problem,
but once i continue to select the next line, the previous line is rendered
again with the overlap problem, indicating that firefox may be trying to render
the hidden text (which is now implicitly selected)

Comment 5

14 years ago
Testcase renders just fine (doesn't look like the screenshot)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Testcase renders just fine (doesn't look like the screenshot)
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

Are you running at 800x600, with text size set to normal?  also, try minimizing
and then maximizing the window.  if a firefox menu covers up the text, when the
menu is hidden, the text will appear correct, but forcing a redraw recreates the
problem for me.

Comment 7

14 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Testcase renders just fine (doesn't look like the screenshot)
> > 
> > Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
> Firefox/1.0
> 
> Are you running at 800x600, with text size set to normal?  also, try minimizing
> and then maximizing the window.  if a firefox menu covers up the text, when the
> menu is hidden, the text will appear correct, but forcing a redraw recreates the
> problem for me.


No, but I tried at 800x600, normal text size, and I forced some redraws, and
still nothing.
(Reporter)

Comment 8

14 years ago
Created attachment 169790 [details]
second test case for overlapping text, in View Source

This test case will demonstrate the problem appearing in the View Source
screen.  should a child bug for the View Source component be created?

What's interesting to me about this test case is that any styles used by View
Source are internal, that is, I wouldn't think this would be caused by bad
markup/formatting.
(Reporter)

Comment 9

14 years ago
Created attachment 169791 [details]
screenshot showing overlapping text in View Source.

This screenshot was created after selecting View Source on the html in the
second html test case.	the html renders correctly, but the problem appears
when viewing the source inside firefox.
(Reporter)

Comment 10

14 years ago
I reported this bug from my parents' computer, and since I've returned home,
I've been unable to reproduce, even though I'm running the exact same version of
the software.  My best guess as to the cause is that it's a hardware/software
driver issue.  Perhaps the way firefox renders offscreen messes up on that
hardware but not most.  Anway, to help reduce the number of open bugs, I'm
marking this worksforme.  If I see it again, I'll suggest reopening this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.