Status

defect
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: iann_bugzilla, Assigned: benjamin)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Using BuildID 2004122809 on WinXP SP2
Steps to reproduce
1. Create new profile and don't import any settings
2. Start Firefox
3. Start DOM Inspector
4. Look in File, Inspect a Window submenu

Expected results
1. Lists DOM Inspector and Browser Window
2. DOM Inspector window has inspection of chrome://browser/content/browser.xul

Actual results
1. Only lists DOM Inspector
2. DOM Inspector window has inspection of browser window's URL

Workaround
1. Close browser window but leave DOM Inspector window open
2. Start firefox again
This just uses the window mediator RDF datasource.  Anyone know why this would
be busted in Firefox?
For some reason, the very first window created by Firefox gets ignored by the
window mediator.  Adding a tab is enough for it to show up on radar.  bsmedberg
fixed this once, not sure why it regressed, but he's probably the best person to
poke on the issue.
Keywords: regression
i thought that was an optimization because firefox didn't want to maintain a
window list unless it was absolutely needed, which it isn't in general (except
on macosx).
bsmedberg, any idea on this one?
I *think* that my commandline rewrite fixed this, at least it seems to work for
me now. But I haven't actually downloaded a nightly build in ages, so somebody
else should probably check.

I personally only ever encountered this problem on linux, never on windows.
It seems starting with mozilla beta2 DOM Inspector shows completely list. I
couldn't reproduce this bug on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b3) Gecko/20050719 SeaMonkey/1.0a .
this was always a firefox bug, never a seamonkey bug. 
Assignee: dom-inspector → benjamin
I'm gonna say this got fixed by 276588
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.