Can copy empty string from location bar

VERIFIED FIXED

Status

SeaMonkey
General
P3
trivial
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Jesse Ruderman, Assigned: leger)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla lets you copy a zero-length string from the URL bar to the clipboard. 
This isn't standard behavior for windows programs.

Comment 1

18 years ago
Haven't been able to reproduce using 2000-02-13-16 on NT, pls reopen if you
still see this.
If you do, please provide steps to reproduce, expected and actual behaviour and
build number.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

18 years ago
Steps to reproduce:
1. In a program such as notepad, select some text and copy it to the clipboard.
2. Go to a website with mozilla (I'm running M13 = #2000012520 on Windows 98)
3. In the URL bar, hover the cursor between two characters.
4. Drag the cursor right and then back (so that the character to the right is 
selected monentarily, but afterward no text is selected)
5. Press Ctrl-C (windows copy key)
6. Try to paste back into notepad.

Expected results:
5 would have no effect on clipboard contents

Results:
Clipboard is cleared.

Note:
I originally thought the clipboard was simply being overwritten by the empty 
string, but I now believe that the clipboard is being erased. If I go through 
step #5 and then paste into notepad, or if I use mIRC 5.7's "/clipboard" 
command (mIRC help file: "Copies the specified text to the clipboard") and then 
paste into notepad, nothing happens. If I select some text before pasting, 
however, /clipboard + paste results in deleting the selection, whereas mozilla 
bug + paste has no effect on what is selected or on the text in notepad.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

18 years ago
I'm still not able to reproduce (build 2000-02-20-16 on NT).

Could you please check with the latest build to see if this has been fixed since

M13. (a LOT of issues have)

If you still see this on the latest build, could you change the component to
'selection' so the right people will be notified of the bug. Otherwise, please
mark fixed.
(Reporter)

Comment 4

18 years ago
Works correctly in latest build.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

18 years ago
Marking Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.