Middle-click does not open in tabs.

RESOLVED DUPLICATE of bug 151249

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 151249
14 years ago
14 years ago

People

(Reporter: Rimbo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

"browser.tabs.opentabfor.middleclick" reports True, and tabs work fine
otherwise.  Using Logitech USB optical scroll wheel mouse, middle-clicking has
no effect.  Middle-click works in other applications (e.g. Safari), just not
Firefox.

Contact me if you need further info about the OS setup, hardware, etc.


Reproducible: Always

Steps to Reproduce:
1. Go to web page with a hypertext link, e.g. http://www.yahoo.com/
2. Middle-click any link
3. ???
4. Profit

Actual Results:  
Nothing.

Expected Results:  
It should have opened the link in a new tab.  Cmd-click does open the link in a
new tab, and you can right-click/ctrl-click and select "Open in new tab" in the
menu.  But I'm used to three-button mice, since I work primarily in Linux.
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
This is fixed and will be available in version 1.1

*** This bug has been marked as a duplicate of 151249 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.