Mail with strict threading like news.

RESOLVED FIXED

Status

MailNews Core
Database
--
enhancement
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Clint Olsen, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I talked with David Bienvenu at length on this, and he agrees that having a
switch to avoid considering the subject line for threading candidates makes
sense.  It avoids annoying your everyday braindead user while allowing power
users to get the most out of their email productivity.  This would use the
References/In-reply-to headers for threading mail just like news does now.

Reproducible: Always

Actual Results:  
Unrelated messages with the same subject line get threaded.

Expected Results:  
Only messages with a References/In-reply-to relationship should get threaded
together.  This would mean that dumb mail clients like Microsoft Outlook (and
Express) would break threading, but who cares about those dolts anyway? :)
(Assignee)

Comment 1

13 years ago
Created attachment 170567 [details] [diff] [review]
proposed fix - add hidden pref "mail.strict_threading"

This adds support for a currently hidden pref "mail.strict_threading" which
will turn off threading by subject for both mail and news (it overrides
"mail.thread_without_re"). The diff also changes the name of an arg in
nsIMsgDatabase.idl for better documentation, and adds a null check to
nsMailDatabase::StartBatch.
Attachment #170567 - Flags: superreview?(mscott)

Comment 2

13 years ago
Comment on attachment 170567 [details] [diff] [review]
proposed fix - add hidden pref "mail.strict_threading"

looks like none of the interfaces are actually changing just changing a
variable name so we don't need to bump the interface IDs right?

Should we just remove this:

+//  NS_ASSERTION(m_readSet, "set is null!");

Is this intentional?
-#ifdef DEBUG_bienvenu
+#ifdef DEBUG_bienvenu1
Attachment #170567 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 3

13 years ago
right, I just changed an arg name in the idl - the ifdef change was intentional.
I can remove the commented out line.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 4

13 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 5

13 years ago
Stop me if I'm wrong, but a) neither of the methods are overridden, so the prefs
are the same for mail and news b) either of the prefs serves to disable strict
threading (although the meanings are reversed).
(Assignee)

Comment 6

13 years ago
yes, the prefs also control news threading - I can't imagine anyone who wants
strict threading in mail isn't going to want it in news. Re b, turning on strict
threading makes us ignore thread by subject w/o re, but turning off strict
threading doesn't make us ignore thread by subject w/o re...so either I'm
confused about what you're saying, or misreading the code.

Comment 7

13 years ago
As I understand this bug it seems to be the same as bug 164115.

Comment 8

13 years ago
Moz 1.8b-0120, I have set this preference to True and I'm still seeing mail 
messages with the same subject (not replies, just monthly updates) being 
organized into a thread:
  First
    -Second
    -Third
    -Fourth
etc.  But, I see the same thing when  mail.thread_without_re  is set False.
Have I misunderstood this bug?

Comment 9

13 years ago
(In reply to comment #6)
>yes, the prefs also control news threading - I can't imagine anyone who wants
>strict threading in mail isn't going to want it in news.
Perhaps someone might only want strict threading in news?
>Re b, turning on strict
>threading makes us ignore thread by subject w/o re, but turning off strict
>threading doesn't make us ignore thread by subject w/o re...so either I'm
>confused about what you're saying, or misreading the code.
If you turn off thread by subject w/o re then you get strict threading anyway
(I think this is might be what Mike Cowperthwaite is trying to say). This means
you only need a separate strict threading pref for news/not news as above.
(Reporter)

Comment 10

13 years ago
So, what version of Thunderchicken has this feature?  I just tried it in 1.0.2
and it's still sifting like subject lines.
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.