If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

first address field can't be edited again when a second has been added - FREEZE

VERIFIED DUPLICATE of bug 26618

Status

SeaMonkey
MailNews: Message Display
P3
critical
VERIFIED DUPLICATE of bug 26618
18 years ago
13 years ago

People

(Reporter: rkaa, Assigned: Phil Peterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bug Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.5-15 i586)
BuildID:    2000021409
When i type in one email address, key enter, then key in another address and
then see an error in the first address and want to correct it, i click on it to
edit, and everything freezes. The last i see of output to console is
"awCopyNode" (no quotes). The processes took up to 90% CPU cycles for 10 minutes
but nothing happened apart from that - had to kill it. It has been like this for
weeks, at least.
Reproducible: Always
Steps to Reproduce:
1.See above
2.
3.
Expected Results:  Should let the user modify addresses after they are typed in.
(Assignee)

Comment 1

18 years ago
Where are you typing these addresses? In the message composition window? The 
Address Book? The Account Wizard?

Comment 2

18 years ago
This sounds like bug #26618
(Reporter)

Comment 3

18 years ago
i use the mail composer window when the bug strikes. The ordinary address fields
there - made a snapshot located at
http://home.powertech.no/rkaa/mailcomposer.gif

I read bug #26618 but in my case the error did not occur when attempting to
reply 3 or more addresses. It happens if i add a second address - both added
manually (not retrieved from address book) - and it seems the mail app confuses
what data is found in what address field. The whole output to console when the
error occured was:

Got focus.
awNotAnEmptyArea
inputElement = [object HTMLInputElement]
select = [object HTMLSelectElement]
select.value = addr_to
aItem = [object HTMLInputElement]
value = dark@c2i.net
aOriginalString = dark@c2i.net
aMatch = dark@c2i.net
awCopyNode
awInputChanged
inputElement = [object HTMLInputElement]
WEBSHELL+ = 11
Got focus.
Got focus.
awInputChanged
inputElement = [object HTMLInputElement]
select = [object HTMLSelectElement]
select.value = addr_to
aItem = [object HTMLInputElement]
value = someone@another.net
aOriginalString = someone@another.net
aMatch = someone@another.net
awCopyNode

- and a struggling freeze after the last output-line there.


(Reporter)

Comment 4

18 years ago
A second though: Wondering if this error has something to do with the fact that
one can't SEND emails now? The composer window merely vanishes and is then
redrawn again. No error messages - it just "boomerangs" like that all the time -
impossible to send anything. Could it be that it doesn't "see" the email
addresses in the adress fields at all? Or somehow doesn't manage to pass them on
to whatever parts of the app that verifies it should be sendt out on the net?
(i'm another newbie bug-reporter as you see ;)
(Assignee)

Comment 5

18 years ago
Yes, now that we know it's in the compose window, it does seem like a dup of 26618


*** This bug has been marked as a duplicate of 26618 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: M14

Comment 6

18 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.