Nested frames don't repaint content on scroll

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
15 years ago
9 months ago

People

(Reporter: jason.polites, Unassigned)

Tracking

({testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
A page with three frames: top, left and right, in which scrolling on the right 
frame is set to AUTO.  When the right frame is scrolled, the content within is 
no repainted correctly.

See the above URL work a reproducable sample
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.0 Branch → Trunk

Comment 1

15 years ago
Posted file supporting file 1

Comment 2

15 years ago
Posted file supporting file 2

Comment 3

15 years ago
Posted file reduced testcase

Comment 4

15 years ago
Confirming.
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: Layout → Layout: HTML Frames
Ever confirmed: true
Keywords: testcase
QA Contact: layout → layout.html-frames
Summary: Frame content repaint → Nested frames don't repaint content on scroll
Seeing this in current trunk Linux too.

Robert, any idea what's up here?
Component: Layout: HTML Frames → Layout: View Rendering
OS: Windows XP → All
Hardware: PC → All

Comment 6

14 years ago
I just tested http://jasen.sourceforge.net/mozbug/ with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

and the problem seems to still be there.
I think this is WFM in my debug build that has the "frame display lists" patch
in it (bug 317375). I can see the bug in normal trunk build.
Depends on: 317375
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012614

WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
No longer depends on: 316489
(Reporter)

Comment 9

12 years ago
This seems to have re-appeared in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
It was fixed, on trunk only, by the checkin for bug 317375.  So of course it's still a problem in 1.8 branch builds...
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

12 years ago
This appears to not be resolved.

Firefox 2.0.0.11
Windows XP

See: 

http://www.jasen.org/mozbug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

12 years ago
The fix will not be present in any of the 2.0 builds. However, when 3.0 is released, it will be fixed there.

This is standard procedure, as the 2.0.* releases are only for critical bugfixes like security or extremely common crashes.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Jason, please try Firefox 3 beta 1 if you want to see the fix?
(Reporter)

Comment 14

12 years ago
Awesome.   Thanks!
(Assignee)

Updated

9 months ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.