Closed Bug 278291 Opened 17 years ago Closed 17 years ago

CSS formatting gives incorrect display of UTF8 characters

Categories

(Firefox :: General, defect)

1.0 Branch
x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 240914

People

(Reporter: gurukumara, Assigned: bugzilla)

References

Details

Attachments

(2 files)

When you use CSS to
1) specify text-align:justify  or
2) specify a value for word-spacing  or
3) specify a value for letter-spacing
to a passage of utf-8 text or it's NCR form the characters are not correctly
displayed.

-=-=-=-=-=-=-= Example =-=-=-=-=-=-=-

<html>
 <head>
  <title>Bug Demo</title>
 <style>
  .tamil_txt{
   
   /* text-align:justify; */
   /* word-spacing:1em; */
   letter-spacing:2px;

  }

 </style>
 </head>

 <body>
 <h3>Sample text in Tamil Language</h3>
	<div>
		மொசில்லா பயர்பாக்ஸ் பிழை (Correctly Displays)
	</div>

	<div class="tamil_txt">
		மொசில்லா பயர்பாக்ஸ் பிழை (incorrect display)
	</div>

	<div class="tamil_txt">
		&#2990;&#3018;&#2970;&#3007;&#2994;&#3021;&#2994;&#3006;
&#2986;&#2991;&#2992;&#3021;&#2986;&#3006;&#2965;&#3021;&#3000;&#3021;
&#2986;&#3007;&#2996;&#3016; (incorrect display)	
	</div>
 </body>
</html>
Summary: CSS formatting gives incorrect display of UTF8 characters → CSS formatting gives incorrect display of UTF8 characters
Whiteboard: DUPEME
(In reply to comment #0)
> When you use CSS to
> 1) specify text-align:justify  or
> 2) specify a value for word-spacing  or
> 3) specify a value for letter-spacing
> to a passage of utf-8 text or it's NCR form the characters are not correctly
> displayed.

This is the same with all indic unicode text. The text gets scattered on using
the above properties. I think this is a serious issue.

Attaching screenshots below..
The screenshot shows the bug. The Unicode is scattered around when the above
mentioned CSS properties are used.
Depends on: uniscribe
Seems to be related to bug 107790.  Feel free to REOPEN if this isn't correct.

*** This bug has been marked as a duplicate of 107790 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No, that's not correct.  Duplicate means _duplicate_, not "related to".  And
this has nothing to do with errors in the byte stream.   It has everything to do
with shaping of Tamil characters and how well we do or don't do it.

Please don't mark bugs duplicate unless you're 100% sure they're duplicate.  If
you have doubts, mark them dependent or something.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
bz is absolutely right (I mid-aired with him...)


*** This bug has been marked as a duplicate of 240914 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Hi, any updates on this? Firefox on win32 is losing out lot of <a
href="http://en.wikipedia.org/wiki/Indic">indic</a> users. :(

Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.