Last Comment Bug 278326 - Server charset takes precedence over page charset
: Server charset takes precedence over page charset
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Simon Montagu :smontagu
: Yuying Long
Mentors:
http://www.ed2go.com/wvcomed/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 18:11 PST by Akkana Peck
Modified: 2005-01-13 18:28 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (60.20 KB, image/jpeg)
2005-01-13 18:14 PST, Akkana Peck
no flags Details

Description Akkana Peck 2005-01-13 18:11:22 PST
The given URL claims this in the http headers:

Content-Type: text/html; charset=WINDOWS-1251

but in the page itself, it says:

<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">

The content of the page is clearly meant to be western, not russian, but mozilla
autodetects it as WINDOWS-1251.  Hence, it displays with a really awful font
(will attach screenshot) because for some reason that font is the one mozilla is
calling up for cyrillic (wish I could figure out what font it is and nuke it!) 
Specifying Western from View->Charsets fixes the font.

I've been seeing this periodically for a long time, over a year, but only just
now traced it to a charset problem.  (Some of the pages where I see it are
incorrectly claiming that charset, and that's their fault, not mozilla's, but in
this particular case the page's meta tag is correct even though the server
isn't.)  It still happens in 1.8a6.
Comment 1 Akkana Peck 2005-01-13 18:14:38 PST
Created attachment 171221 [details]
screenshot
Comment 2 Jungshik Shin 2005-01-13 18:25:28 PST
see my comment in bug 278325
Comment 3 Jungshik Shin 2005-01-13 18:28:48 PST
(In reply to comment #0)

> (will attach screenshot) because for some reason that font is the one mozilla is
> calling up for cyrillic (wish I could figure out what font it is and nuke it!) 

It seems like you're using Gtk1+X11core font build. You'd get a lot better
rendering if you download 'gtk2+xft' build (go to
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases) and download one with
'gtk2+xft' in its name.

Note You need to log in before you can comment on or make changes to this bug.