Firefox needs to support CSS3 print commands. Specifically Page Layout header/footer and print page margins.

RESOLVED DUPLICATE of bug 189597

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED DUPLICATE of bug 189597
14 years ago
13 years ago

People

(Reporter: Bradley Stec, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803

Many web applications could be migrated to a pure web browser based solution
with built-in CSS3 support in Firefox.  Specifically the age-old problem of
exacting printed page results.  I'm trying to find a browser-only solution to
doing away with the printed page header/footer and some control over print
margins so I can create print perfect forms on a printer.  This is currently not
possible without adding ActiveX, Java Print Control Applet or converting the
whole thing to PDF and sending to the printer with that.  CSS3 has these
commands in its specification and can open a whole new genre of web applications
if control is given to the web content developer to control the printed output
of a page.  Can we build this into FireFox?

Reproducible: Always

Steps to Reproduce:
1.  Load up a web page.
2.  Print to your printer.
3.  Note that the page has been sized to fit within the print margins and that
the header and footer are sources from the browser.  These settings are
controlled by the browser and the user must pull down menues to change them. 
Solutions to date are kludgy and require constant maintenance.  Building support
for CSS3 into FireFox would solve all those problems and draw corporations to
use it more fervently.

Updated

14 years ago
Assignee: bugs → dbaron
Component: OS Integration → Style System (CSS)
Product: Firefox → Core
QA Contact: os-integration → ian
Version: unspecified → Trunk

Comment 1

14 years ago
Hmm, isn't this part of bug 115199? Albeit that that bug is now specifically
"aimed" at CSS2 support.
(Reporter)

Comment 2

14 years ago
CSS3 includes and enhanced version of the @page functionality that allows
control of device margins and headers and footers:

http://www.w3.org/TR/css3-page/

The @media tag would be an ideal as well being able to have total control over
output device width/height, however reaching that far to device control with the
browser may make it difficult to keep the code portable.

http://www.w3.org/TR/css3-mediaqueries/#device-width

These specifications will open up a myriad of doors for new possible print
applications with FireFox (labels, tickets, coupons, ...) and dramatically
improve the print abilities of existing applications (receipts, maps, forms,
phone directories...)

Thanks.
Brad

Comment 3

13 years ago
Bug 189597 requests almost the same and is much older. I'm going to mark it as a
duplicate of that bug now there is also a generic bug requesting everything from
the paged media module.

*** This bug has been marked as a duplicate of 189597 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
No longer depends on: 115199
You need to log in before you can comment on or make changes to this bug.