mailto: links in html no longer manages ?subject parameter

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: pascalc, Assigned: Ahn Dal-Soo)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Build : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111

Reproducible : always
1 have a mailto link like :
<a href="mailto:foo@bar.com?subject=test">
2 click on the link

expected result : a mail compose window with the To field containing foo@bar.com
and the subject field with the string "test"

actual result : The to field contains foo@bar.com?subject=test

This is a recent regression
(Reporter)

Updated

13 years ago
Flags: blocking1.8b?
Pascal: how recent?  Then we can narrow down the checkins...

Updated

13 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
It's between 1.8a5 and 1.8a6, have no time to test nightly builds currently sorry

Comment 3

13 years ago
OK, I have found the build where things went south.  Keep in mind I'm am just a
newbie so forgive me if I left something out.  Here is the info for the last
know good build and the first know bad build.

Last good build info
--------------------
FTP Filename  -
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2005-01-11-06-trunk/mozilla-win32-installer.exe

Window Title  - Mozilla {BuildID:2005011105}

about:Mozilla - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20050111

First bad build info
--------------------
FTP Filename  -
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2005-01-11-17-trunk/mozilla-win32-installer.exe

Window Title  - Mozilla {BuildID:2005011116}

about:Mozilla - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20050111

I hope this helps.  Please let me know if there is any other info you need.

Comment 4

13 years ago
A little more info.  The problem persists through to the very latest build I
could download.  Here is the build info:

Latest bad build info
---------------------
FTP Filename  -
ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2005-01-20-06-trunk/mozilla-win32-installer.exe

Window Title  - Mozilla {BuildID:2005011116}

about:Mozilla - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6)
Gecko/20050111

Comment 5

13 years ago
(In reply to comment #3)
> OK, I have found the build where things went south.  

Checkins to module MozillaTinderboxAll (Mozilla Trunk) between 2005-01-11 05:00
and 2005-01-11 16:00:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-01-11+05%3A00&maxdate=2005-01-11+16%3A00&cvsroot=%2Fcvsroot
Johnny, know anything about this bug?
Actually, there's a good chance this is bug 274264, since that would have
affected escaping behavior of URIs...
And in fact, that patch will end up escaping the '?' in that URL, as far as I
can see (we used to only unescape non-ascii, but now we unescape everything, and
then reescape, with the result that things that were not escaped to start with
end up escaped).

Reassigning to author of that patch.
Assignee: sspitzer → ahndalsoo
Severity: normal → major
Depends on: 274264
(Assignee)

Comment 9

13 years ago
It is not a good idea to unescape everything and reescape the result. Once we
unescape everything, there is no way to distinguish two question symbols in such
a case, "foo@bar.com?subject=how are you?". The first symbol should keep
unescaped while the second symbol should be escaped.

bug 274264 is specific to ShiftJIS code and affects only Japanese Windows.
Please back out my patch. As of now I have no working solution not to mess up
URI in every case.
I backed out the patch in bug 274264 from the trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
(In reply to comment #10)
> I backed out the patch in bug 274264 from the trunk.

Verified.  Trunk 2005-01-24-06-trunk (win32) handles mailto: properly now. TY
Verified FIXED for me with build 2005-01-24-05, Windows XP.
Status: RESOLVED → VERIFIED

Comment 13

13 years ago
*** Bug 280160 has been marked as a duplicate of this bug. ***

Updated

13 years ago
OS: Windows XP → All

Comment 14

13 years ago
*** Bug 281861 has been marked as a duplicate of this bug. ***
Flags: blocking1.8b?

Comment 15

13 years ago
*** Bug 289770 has been marked as a duplicate of this bug. ***

Comment 16

12 years ago
This bug is not fixed in the latest trunk build (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051030 SeaMonkey/1.1a)

Comment 17

12 years ago
The testcase worked for me with SeaMonkey build 2005102909.

Comment 18

12 years ago
(In reply to comment #16)
> This bug is not fixed in the latest trunk build (Mozilla/5.0 (Windows; U;
> Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051030 SeaMonkey/1.1a)
> 
Sorry, messed up with windows regional settings - my mistake, it works fine.
You need to log in before you can comment on or make changes to this bug.