If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XML format for bug activity

RESOLVED DUPLICATE of bug 112646

Status

()

Bugzilla
Bug Import/Export & Moving
P3
enhancement
RESOLVED DUPLICATE of bug 112646
13 years ago
7 years ago

People

(Reporter: sheng han, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0

As I know of, many people is trying, had tried to hack bugzilla to suit their
own consent including me. One of the most hairy task in hacking bugzilla is to
retrieve bugs related data from bugzilla ( to manipulate it, to syncronize with
other in some strange way, to do sanity check and to automate some process ...). 

I don't want to discuss how to retrieve bugs related information in this one,
instead I would like to find out if its possible to have a standard format of
output --- XML form of bugs.

This XML output will contains all information of a bug, including activity,
attachments, longdescs etc.. Which means its a data dump from mysql in a nice
formated way.

With this XML output, hacker can easily build XML object in their language,
manipulate with a official recognized format. I think this can help to
formalized the project structure in the future, plus provide API based on the 
XML object.

Since this can be a data dump, it can/should also output other tables data in a
meaningful way, i.e. with association to a bug's attribute.



Reproducible: Always

Comment 1

13 years ago
Have you seen https://bugzilla.mozilla.org/show_bug.cgi?ctype=xml&id=278832 -
while its not the full data, it does go someway to providing the information you
want?
(Reporter)

Comment 2

13 years ago
Yes, I've seen the ctype option. I learned it from the xml.cgi and that's what
my idea originated from. 

Colin,
What do you think about my idea? Will it be useful?
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → import-export
It seems to me this is very much related to bug 112646, bug 233984 and bug
285614... Is it a duplicate? Or will they maybe together fix this bug?

Comment 5

12 years ago
Just wondering whether anything's happening with this one, or whether I'm
looking in the wrong place?

Comment 6

12 years ago
look also at bug 302669

Updated

11 years ago
Priority: -- → P3
Summary: Output XML as full bug data → XML format for bug activity

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: Sun → All

Updated

9 years ago
Blocks: 449137
This bug has been morphed into a request for an XML format for bug activity. Bug activity is available programmatically via the WebServices API:
http://www.bugzilla.org/docs/3.4/en/html/api/Bugzilla/WebService/Bug.html
(see the Bug.history call).

Is that sufficient?

Gerv

Comment 8

7 years ago
(In reply to comment #7)
> Bug activity is available programmatically via the WebServices API:
> Is that sufficient?

I think it is. And if you want it included in the bug XML file, then that's bug 112646, which I'm duping this bug to.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 112646
You need to log in before you can comment on or make changes to this bug.