Closed Bug 278857 Opened 15 years ago Closed 15 years ago

firefox fails to understand backslash as forwardslash, Internet Exporer does

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: prince01891, Assigned: bugzilla)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 



Try making a link:
Say, a hypothetical page (THAT EXISTS), but try opening it with the following 
link in Internet Explorer:
http://www.foo.com\test.html (Original link)

IE will resolve it as:
http://www.foo.com/test.html

Now, try opening the same (original, incorrect) link in Firefox.

Firefox will not be able to resolve this wrong link.

I suggest this should be resolved.

--------

PLEASE NOTE: foo.com/test.html is a dummy page that DOES NOT EXIST. YOU WILl 
need to create your own such link.

Reproducible: Always

Actual Results:  
http://www.foo.com\test.html cannot be resolved.

Expected Results:  
resolve the link correctly.

http://www.foo.com\test.html

should have resolved in Firefox as:
http://www.foo.com/test.html
just as it does in Internet explorer
-> invalid

per RFC: A "\" must be escaped and Mozilla (including Firefox) does this correctly.
Ie is broken in this case.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
correct, "\" is an invalid character in URL's
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.