BUG MAIL JAVASCRIPT - FUNCTION GENRE

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: lucianolll, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20050111

<p>
CORRECT 
</p>
<script type="text/JavaScript">
function mailpage()
{
mail_str = "mailto:?subject= Faz Fácil - O site que ensina a fazer ! " ;
mail_str += "&body= Achei este site muito interessante:  "+ document.title;
mail_str += ".  O endereço é: "+ location.href;
location.href = mail_str;
}
</script>
<a href="javascript: mailpage()">Mail</a><br/>

<p>
BUG - ERROR IN FUNCTION - Mail To - question ? - Mozilla 1.8a6 -
</p>

<a
href="javascript:location.href='mailto:?SUBJECT='+document.title+'&BODY='+escape(location.href)">Send
Location</a>

<p>
BUG - ERROR IN FUNCTION - Mail To - question ? - Mozilla 1.8a6 -
</p>

<a href="
javascript: document.location.href='mailto: ?subject='+ document.title
+'&body=<br/>'+ document.title + '<br/><br/>'+  escape(document.location) +'
<br/>'; void(0)
">MailTo</a><br/>

<p>
BUG - ERROR IN FUNCTION - Mail To - question ? - Mozilla 1.8a6 -
</p>

<a href="
javascript: function mailpage() { var mailstr='mailto:?subject=ddd';
location.href=mailstr; }; mailpage();
">MailTo d</a><br/>

<p>
BUG - ERROR IN FUNCTION - Mail To - question ? - Mozilla 1.8a6 -
</p>

<a href="mailto: ?subject=ddd">ddd</a><br/>

Reproducible: Always

Steps to Reproduce:
1. Every

Actual Results:  
?subject= 
? no load script

Expected Results:  
Format script
Functional Script
Mail Location body
<a href="
javascript: location.href='mailto:?subject='+ document.title +'&body=<br/>'+
document.title + '<br/><br/>'+  escape(document.location) +' <br/>'; void(0)
">Mail Location body</a><br/>
(Reporter)

Comment 1

14 years ago
Created attachment 171714 [details]
Test Mail Bug 1a6

Test JavaScript Functions

Comment 2

14 years ago
*** Bug 278938 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
Please read http://www.mozilla.org/quality/bug-writing-guidelines.html and file
a new bug report. This report here is useless.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.