If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Additional Mail Accounts display "Local Folders" identity panel

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Account Configuration
P3
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix in hand)

(Reporter)

Description

18 years ago
Build 2000-02-15-09M14: NT4
Build 2000-02-14-16M14: Linux 6.0 
Build 2000-02-14-13M14: Mac 8.5.1

Overview: After adding a second Mail account, the Identity panel in Account 
Settings appears to be the same dialog as the "Mail Folders" where it states 
that its a special account.

Steps to reproduce:
1. Use a profile that has one mail account
2. Use the Account Wizard to add a second mail account.
3. After selecting the "Finish" button on the Congratulations dialog the Account 
Settings window should appear.
4. Select the second mail account's Identity panel.

Actual Results: Notice that the dialog looks like the "Mail Folders" dialog and 
it states 
- "The following is a special account. There are no identities associated with 
it." 
- It displays the Account Name correctly.
- The Server panel looks ok.
- The Copies panel look ok.
- Click "OK" to close Account Settings, then open Account Settings and the 
Identity panel for the second account now looks correct.

Additional Information:
- This also happens if you add a News account.
(Reporter)

Comment 1

18 years ago
Correction: When I refered to "Mail Folders" I meant "Local Folders".
QA Contact: lchiang → nbaca
(Assignee)

Comment 2

18 years ago
this is really bad. Newly created accounts should not display this panel
Status: NEW → ASSIGNED
Keywords: beta1
Target Milestone: M14

Comment 3

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Comment 4

18 years ago
figured out what was going on, have the fix
The problem was that NotifyServerLoaded was happening whenever an incoming
server was created, independant of whether it was actually in an account... this
meant that there were no identities associated with the account, so the
datasource would tell the account manager to show the no-identities page.

I changed it so that the notification happens when you attach it to an account,
so that you can attach identities to the account before attaching the server,
and then when the server is attached, THATs when the datasource would add the
server to the account list, and it would have identities by then.
Whiteboard: [PDT+] → [PDT+] fix in hand
(Assignee)

Comment 5

18 years ago
ok, fix is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Build 2000-02-22-16M14: NT4
Build 2000-02-22-12M14: Linux 6.0
Build 2000-02-22-11M14: Mac 8.5.1
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.