Keys swallowed when typing into a textarea or input

VERIFIED FIXED

Status

()

VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Biesinger, Assigned: aaronlev)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

seen in location bar, bugzilla CC list <input>, and this textarea

When typing, keys are swallowed. For example, right now when typing into this
textarea, a lot of characters do not show up at first. Typing more slowly will
fix the problem.

Unsure about the component, picking widget:gtk for now.

this might be caused by bug 167145

linux/gtk2/seamonkey, checkout finish: Do Jan 20 14:27:25 CET 2005
(Assignee)

Comment 1

14 years ago
Created attachment 171906 [details] [diff] [review]
Careful about uninitialized status variable
(Assignee)

Updated

14 years ago
Assignee: blizzard → aaronleventhal
Status: NEW → ASSIGNED
Attachment #171906 - Flags: superreview?(bzbarsky)
thanks, this does fix the problem for me.
Attachment #171906 - Flags: superreview?(bzbarsky)
Attachment #171906 - Flags: superreview+
Attachment #171906 - Flags: review+
(Assignee)

Comment 3

14 years ago
Checking in nsWindow.cpp;
/cvsroot/mozilla/widget/src/gtk2/nsWindow.cpp,v  <--  nsWindow.cpp
new revision: 1.128; previous revision: 1.127
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
Yes, work much better again. Thanks for working out the fix that fast!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.