Can't switch windows with Alt-TAB when drop down is active

VERIFIED WONTFIX

Status

()

P3
normal
VERIFIED WONTFIX
19 years ago
8 years ago

People

(Reporter: djoham, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

241 bytes, text/html
Details
(Reporter)

Description

19 years ago
From Bug Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.12-20 i686; en-US)
BuildID:    2000021510
Environment:
RH Linux 6.1
KDE 1.1.2

When you click to activate a drop down box (created with the HTML code <SELECT
SIZE=1>.....</SELECT>) the system's capability to ALT-TAB to switch to other
open windows is disabled.

Reproducible: Always
Steps to Reproduce:
1.go to any web site that has a drop down box (I'll include a test case)
2.click on the arrow to activate the drop down.
3.Try to ALT-TAB to move to another window.

Actual Results:  Your keystrokes will be ignored and you won't be able to switch
to any other windows.	
Expected Results:  I would expect to be able to use ALT-TAB to switch to other
windows	
I don't have Mozilla on my Windows partition so I haven't been able to test on
that platform.
(Reporter)

Comment 1

19 years ago
Created attachment 5302 [details]
test case

Comment 2

19 years ago
Hm. I'm running Gnome, and here, when you activate a menu, you can't Alt-Tab
between windows.  So this is what I'd expect.  See also bug 26509.  Reassign to
pavlov.
Assignee: leger → pavlov
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: cbegle
(Reporter)

Comment 3

19 years ago
Interesting. Y'know, I've never noticed this about GNOME applications until you
mentioned it. However, I checked the behavior in GNOME with drop downs, and you
can still ALT-TAB when one is activated. I can live with the menus (although I
would prefer to be able to ALT-TAB whenever I wanted to) but IMHO, I still think
this is a bug.

Thanks!

David

Comment 4

19 years ago
Another comment: on KDE apps, Alt makes the menu go away.  So when you click on
the menu bar, then press Alt-Tab, the menu goes away first, then focus switches.

As djoham points out, when you activate a pulldown select field in a Gnome
application and click Alt-Tab, the focus does switch.  However, the menu stays
on top; just like it used to in Mozilla (bug 26509).
Summary: Drop down boxes disable ALT-TAB capabilities between open windows → Can't switch windows with Alt-TAB when menu active
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 5

19 years ago
It is behaving correctly.
(Reporter)

Comment 6

19 years ago
I'd just like to make sure that we're all clear on the original intent of the
bug report. The original problem was not that you couldn't ALT-TAB when a menu
was active. It was that you couldn't ALT-TAB when a drop down was active. This
is different behavior than both KDE and GNOME. Since I believe that this is a
bug, I'm just making sure that we're all on the same page before the bug gets
officially closed. 

I'm not sure if my original summary was incorrect or if there was a
miscommunication between Zach and I and one of us changed it, but the subject as
it was (Can't switch windows with ALT-TAB when menu active) is misleading. I've
updated the subject to be more descriptive.

David
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Can't switch windows with Alt-TAB when menu active → Can't switch windows with Alt-TAB when drop down is active
(Assignee)

Comment 7

19 years ago
no, in GNOME and Netscape 4.x, you can not ALT TAB while menus are open.  I
understand the bug, and I don't believe this to be a real bug.  Closing again.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WONTFIX

Comment 8

17 years ago
Sounds good to me, marking verified
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.