firefox-installer crash on line 56 --- free(): invalid pointer 0x8235a10! Mandrake 10.1

VERIFIED DUPLICATE of bug 261194

Status

()

Firefox
Installer
--
critical
VERIFIED DUPLICATE of bug 261194
14 years ago
12 years ago

People

(Reporter: Gary Rust, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

1.0 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804

[garyrust@www firefox-installer]$ ./firefox-installer
SCIM: im_module_init
free(): invalid pointer 0x8235a10!
free(): invalid pointer 0x82359e8!
./firefox-installer: line 56: 22188 Segmentation fault      ./${BINNAME}-bin $@
[garyrust@www firefox-installer]$ ./firefox-installer: line 56: 22188
Segmentation fault      ./${BINNAME}-bin $@[garyrust@www firefox-installer]$
./firefox-installer
bash: ./firefox-installer:: No such file or directory


Reproducible: Always

Steps to Reproduce:
1.execute firefox-installer as root
2.
3.

Actual Results:  
Install screen came up. I clicked on button and got 
invalid pointer
after SCIM: im_module_init  (see details)

Expected Results:  
failed install because of seg fault

SCIM: im_module_init on firefox-installer
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch

Updated

14 years ago
Keywords: crash

Comment 1

14 years ago
can you grab a stacktrace with gdb?

env LD_LIBRARY_PATH=. gdb firefox-installer-bin

(gdb) run
[installer crashes]
(gdb) bt

paste the output of "bt" here

Comment 2

13 years ago
Isn't it a dupe of 261194 ?

Comment 3

13 years ago
yup

*** This bug has been marked as a duplicate of 261194 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.