[Firefox] Localization (e.g., de_DE) breaks Windows XP's handling of html file + folder as pair/unit

RESOLVED FIXED

Status

Mozilla Localizations
de / German
--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Tom Link, Assigned: atopal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0

When I save a web page with the English version of Firefox as NAME.html,
auxiliary files are saved in a NAME_files folder. The Win XP file explorer can
be tuned to handle this file and the folder as one unit on commands like
copy/move/delete. When I use the German version of Firefox, the folder for
auxiliary files is called NAME_dateien so that even the German version of Win XP
doesn't recognize the file and its folder as a pair/unit any longer.

Reproducible: Always

Steps to Reproduce:
1. Run a localized verison of FF on Win XP
2. Save some page
3. Delete/copy/move the html file

Actual Results:  
Only the file gets deleted/copied/moved

Expected Results:  
The file and the folder should be deleted/copied/moved. The name of the folder
should be NAME_files in all localizations. (Or there should be an option to set
this.)

Comment 1

14 years ago
I guess this should be Product/Component Mozilla Localizations/German.
Summary: Localization (e.g., de_DE) breaks Windows XP's handling of html file + folder as pair/unit → [Firefox] Localization (e.g., de_DE) breaks Windows XP's handling of html file + folder as pair/unit
reporter: are you using an English version of WinXP or a German one?

Comment 3

14 years ago
Actually, could we get the "right" suffix from the OS?
Like, this will of course break as soon as you move the combo from one 
localisation of XP to another, but the "right" suffix isn't determinded by the
FF localisation, but the XP localisation.
I heard that the german localisation uses _Dateien, but the OS expects -Dateien.
So MS invented some involved ways we can fail here.
Ugly, can you say "win me over".
Status: UNCONFIRMED → NEW
Ever confirmed: true
After a short discussion on IRC with Pike and KaiRo, we came to the conclusion
that this is indeed a bug in the German Firefox.
It makes "NAME_Dateien", but WinXP expects "NAME-Dateien".

Confirming and reassigning.
Assignee: firefox → a.topal
Component: General → German-Austria/de-AT
Product: Firefox → Mozilla Localizations
QA Contact: general → mmx_bugzilla

Comment 5

14 years ago
I think this is - in the current state - really German only.
We have translated the name in SeaMonkey German, so I think that it's possible
to do that in Firefox as well.

But there's possibly a more intelligent way to a solution:
<Pike> KaiRo: I wonder if there's a way to get the right string from the OS
<Pike> as that is an OS localisation thing, not a FF localisation thing (at
least to some 70%)
<MMx> really? does it depend on the locale of the OS?
<KaiRo> MMx: yes, I believe it does

From what I heard, I believe a German Windows doesn't even recognize "_files"
correctly, it only knows "-Dateien" (FF de uses "_dateien" though).

So, surely, it should be corrected to "-Dateien" on FF German, but we should
investigate if we can get the correct string from the OS...

Comment 6

14 years ago
This could affect other localizations also. Swedish Windows XP recognize
"_files" and "-filer", but not "_filer" which we have used in the sv-SE
localization.
(Reporter)

Comment 7

14 years ago
(In reply to comment #2)
> reporter: are you using an English version of WinXP or a German one?

I use the German version. My first impression was that using _files is a safe
bet and a solution that works even when moving files from a localized (e.g. at
home) to an English version (e.g. at work) of Windows. I now realized that my
German version also recognizes the -filer suffix mentioned in another posting.
So it would probably be ok to use -Dateien in the German version (a dash instead
of an underscore). _filer and _Dateien are not recognized.
(Reporter)

Comment 8

14 years ago
> I now realized that my
> German version also recognizes the -filer suffix mentioned in another posting.

Interestingly, it doesn't recognize -files.
(Assignee)

Comment 9

14 years ago
So _files works but _dateien doesn't? What a mess, grrr.
I'll change this for the next Firefox release to -Dateien.
Status: NEW → ASSIGNED

Comment 10

13 years ago
Additional Information: As discribed on
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/shell/programmersguide/shell_basics/shell_basics_programming/manage.asp
there are the following predefined names for use with the windows feature
"connected files": "_archivos", "_arquivos", "_bestanden", "_bylos",
"-Dateien", "_datoteke"	, _dosyalar", "_elemei", "_failid", "_fails",
"_fajlovi", "_ficheiros", "_fichiers"	, "-filer", ".files", "_files", "_file",
"_fitxers", "_fitxategiak", "_pliki", "_soubory", "_tiedostot".

Therefore the correct translation for "_files" is indeed '-Dateien'. Note that
the german String hat '-' as their first character rather than '_'.
What the <censored> where they thinking when they changed it to "-" instead of
"_" for two (2) languages? What about consistency? (Except at sucking)
Blocks: 307082
(Assignee)

Comment 12

13 years ago
fixed due to yesterdays checkin.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.