Closed Bug 279752 Opened 15 years ago Closed 15 years ago

FF crashed while clicking on link while still loading page [@ nsEventStateManager::GenerateMouseEnterExit]

Categories

(Core :: DOM: UI Events & Focus Handling, defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 279205

People

(Reporter: lama77, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050123 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050123 Firefox/1.0+

While using one of our intranet sites (not accessible from outside) FF recent
build crashes with Talkback provided (TB3278774Z) if I click on one of the top
frame links while still FF is loading bottom frame.

Reproducible: Sometimes

Steps to Reproduce:
1. Visit the site 
2. Click on the top frame link before bottom frame of site's load is complete
3.

Actual Results:  
FF crash

Expected Results:  
Pages should load ok.
0x021372dc
nsEventStateManager::GenerateMouseEnterExit 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 2618]
nsEventStateManager::PreHandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 474]
PresShell::HandleEventInternal 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 5902]
PresShell::HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp,
line 5761]
nsViewManager::HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2432]
nsViewManager::DispatchEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2151]
HandleEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 174]
nsWindow::DispatchEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1103]
nsWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5402]
ChildWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5653]
nsWindow::WindowProc 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1389]
USER32.dll + 0x86cb (0x77d486cb)
USER32.dll + 0x879f (0x77d4879f)
USER32.dll + 0x8a31 (0x77d48a31)
USER32.dll + 0x8ab4 (0x77d48ab4)
nsAppStartup::Run 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/toolkit/components/startup/src/nsAppStartup.cpp,
line 146]
main 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 60]
kernel32.dll + 0x2141a (0x77e8141a)
Assignee: firefox → events
Severity: normal → critical
Component: General → Event Handling
Keywords: crash
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
It looks like the stack in bug 204781 (fixed 2003) matches this one...
Summary: FF crashed while clicking on link while still loading page (nsEventStateManager::GenerateMouseEnterExit) → FF crashed while clicking on link while still loading page [@ nsEventStateManager::GenerateMouseEnterExit]
The crash is quite random and have only managed to reproduced in on this
intranet site.. got it to crash again to day with TB3301342W on the
20050123-trunkbuild.
Think I managed to recreate problem on a normal "internet site",
http://www.amv.se/rdfs.asp?L=29
and clicking on the left hand frame link called "Platsbanken" before the full
frame was loaded.
TB3322628K was created.
Actually found another bug which acatually matches my problem. Tried the latest
trunk and WFM now. Resolving myself.

*** This bug has been marked as a duplicate of 279205 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsEventStateManager::GenerateMouseEnterExit]
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.