error loading xslt stylesheelt which uses the document('') function to refer to the stylesheet

RESOLVED DUPLICATE of bug 205778

Status

()

Core
XSLT
--
critical
RESOLVED DUPLICATE of bug 205778
13 years ago
13 years ago

People

(Reporter: Stefan Eissing, Assigned: peterv)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

We server XML files with XSL stylesheet instruction. The stylesheet uses the
document('') call to refer to itself on selection, like this:

<data:numbers>
  ...
</data:numbers>
<xsl:variable name="test" select="document('')/*/data:numbers" />

Observation: Firefox seems to load this page endlessly, becoming unresponsive in
the process. The same page loads quickly and flawlessly on a Windows box using IE.

Assumption: the implementation of the document() function has no shortcut for
the empty URI reference and resolves '' to the URI of the stylesheet and tries
to load that stylesheet - which leeds to an endless recursion.



Reproducible: Always

Steps to Reproduce:
Use xml with stylesheet with documnet function to itself as decrivbed above.
Loading the stylesheet directly works since the document() function is then not
executed.
Actual Results:  
Application hanging.


Behaviour is the same on OS X and Win2k.

Comment 1

13 years ago
Same behaviour on W2K.
(Reporter)

Updated

13 years ago
Component: General → XSLT
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Assignee: firefox → peterv
QA Contact: general → keith

*** This bug has been marked as a duplicate of 205778 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Oh, and please remember to reassign to default owner when changing component.
Otherwise it's easy to miss the bug since bugzilla doesn't allow you to
subscribe to components.
You need to log in before you can comment on or make changes to this bug.