All users were logged out of Bugzilla on October 13th, 2018

Page layout doesn't look right (colspan=0)

VERIFIED FIXED in M15

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: bwp6, Assigned: karnaze)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The new dell website doesn't look right after the home page.  The layout of the
tables seem to shift right.

Comment 1

19 years ago
Created attachment 5319 [details]
Testcase

Comment 2

19 years ago
Problem is caused by COLSPAN="0"
Keywords: testcase
(Assignee)

Comment 3

19 years ago
Nav4.x does not support the html 4 colspan=0 and treats it like colspan=1. The 
attachment gives an error condition involving colspan=0. colspan=0 means the 
cell spans to the end of the table. If cells follow it on the same row then it 
is up to the ua how to deal with it. Anyway, I will add a NavQuirks hack to turn 
colspan=0 into colspan=1 and that will fix the problem for pages that rely on 
this behavior.
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 4

19 years ago
*** Bug 29483 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

19 years ago
Adding (colspan=0) to summary.
Summary: Page layout doesn't look right → Page layout doesn't look right (colspan=0)

Comment 7

19 years ago
*** Bug 29792 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

19 years ago
rowspan/colspan=0 now only works according to HTML 4 in strict mode. There are 
pages relying on the behavior where a value <= 0 becomes 1.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Using 7/13 build, table working correctly in Nav Quirks. Colspan of 0 = 1. 
Verifying bug fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.