Too many tabs overlap with "close tab" ([X]) button

VERIFIED DUPLICATE of bug 221684

Status

()

VERIFIED DUPLICATE of bug 221684
14 years ago
14 years ago

People

(Reporter: ezar, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In case of open many tabs some tabs are out of tab bar and last visible tab 
overlaped with "close tab" (white [X] on red background)button.

Reproducible: Always

Steps to Reproduce:
1. Open the page with many links, ex. http://lenta.ru or any other news. 
2. Open links one by one "in new tab" (in my case at 1024*768 videomode 33 tabs 
is enought).

Actual Results:  
Last tab is overlapped with "close tab" ([X]) button. Next new tab will be 
opened somewhere out of screen. Clicking on overlapped place closing current 
tab.

Expected Results:  
There are some posibilities. 
1. Browser can prevent from opening more tabs than it can show in the tab bar 
(worst solution).
2. Tab bar can be expanded to more than one line.
3. All homeless tabs plus one can be hided and last one replasing with pair of 
navigation buttons ("<" and ">"). 
4. Above solutions can be implementing together and behaviour of tab bar can be 
selected by user.

*** This bug has been marked as a duplicate of 221684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.