If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Currency amounts following the pound character (£ or hash) do not display correctly

RESOLVED DUPLICATE of bug 248304

Status

Camino Graveyard
Page Layout
RESOLVED DUPLICATE of bug 248304
13 years ago
4 years ago

People

(Reporter: pedmond66-mozilla, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041201 Camino/0.8.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041201 Camino/0.8.2

On many sites (the above is just one random example), currency amounts shown in
pounds sterling (i.e. following the pound-sign character) don't display
correctly (usually as a ? followed by a zero).

On the site above, see, for example, the last line in the table: "International
Fees". Camino shows "Registration Fee � Balance �000 (payable by module)#"
whereas Firefox (1.7.5) shows "Registration Fee £750 Balance £10,000 (payable by
module)#". The latest nightly build of Camino still has the problem.

I see this problem on many (but not all) sites displaying UK currency amounts.
If it is related to non-compliance of web pages with standards, shouldn't Camino
at least treat them the same as other Mozilla broswers?


Reproducible: Always

Steps to Reproduce:
1. No setup needed - just load an offending page

Actual Results:  
In the case of the website example above, "£750" was displayed as "?" and
"£10,000" as "?000".

Expected Results:  
I would expect the pound sign to be recognised as a character to be displayed
normally rather than as (perhaps?) some sort of escape sequence.
(Assignee)

Comment 1

13 years ago
this is a dupe. the workaround is to manually set the page encoding in the view
menu.
Whiteboard: DUPEME

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 248304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.