Last Comment Bug 280215 - [FIX]shouldn't reload pages when going back from page with anchor to original page (foo#bar -> foo)
: [FIX]shouldn't reload pages when going back from page with anchor to original...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: x86 Linux
: P1 normal (vote)
: mozilla1.8beta1
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
http://www.w3.org/TR/xmlschema-1/
Depends on:
Blocks: 273158
  Show dependency treegraph
 
Reported: 2005-01-28 09:37 PST by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2008-11-17 14:35 PST (History)
1 user (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.74 KB, patch)
2005-01-28 10:06 PST, Boris Zbarsky [:bz]
cbiesinger: review+
darin.moz: superreview+
Details | Diff | Review

Description Christian :Biesinger (don't email me, ping me on IRC) 2005-01-28 09:37:10 PST
 
Comment 1 Christian :Biesinger (don't email me, ping me on IRC) 2005-01-28 09:40:57 PST
bah, accidentally hit enter.

When loading a page, and clicking an anchor in it, then going back, the page is
reloaded. this sucks for large pages, since they take long to load even from cache.

Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2005-01-28 09:42:23 PST
most likely a regression from Bug 273158
Comment 3 Boris Zbarsky [:bz] 2005-01-28 10:06:24 PST
Created attachment 172701 [details] [diff] [review]
Patch

This basically removes the patch in bug 273158 and refixes that bug in a
slightly less intrusive way (only for non-history loads).
Comment 4 Christian :Biesinger (don't email me, ping me on IRC) 2005-01-28 10:27:28 PST
Comment on attachment 172701 [details] [diff] [review]
Patch

+    if (hashNew < 0 && (hashCurrent < 0 || aLoadType != LOAD_HISTORY)) {

can you make those comparisons to kNotFound instead?

with that, r=biesi
Comment 5 Darin Fisher 2005-01-30 12:44:12 PST
Comment on attachment 172701 [details] [diff] [review]
Patch

sr=darin (with same nit as biesi)
Comment 6 Boris Zbarsky [:bz] 2005-01-30 14:08:42 PST
Fixed.

Note You need to log in before you can comment on or make changes to this bug.