No option to turn off "no ecryption" for TLS.

RESOLVED EXPIRED

Status

()

--
minor
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: jeb, Assigned: bugs)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

This web site me to disable the no encryption on TLS.

Reproducible: Always

Steps to Reproduce:
Go to http://www.aetnanavigator.com




Actual Results:  
Redirected to http://member.aetna.com/member_registration/encrypt_err_real.html

Expected Results:  
Presented a login page.

Comment 1

14 years ago
Works for me with Firefox 1.0 release and Mozilla 1.8b on WinNT4. 
With Mozilla 1.8b I can (or is default?) disable the "no encryption" for TLS.
See Preferences - Privacy/Security - SSL - Edit Ciphers - Extra SSL3/TLS.
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

14 years ago
This is a Firefox issue.  Mozilla has the dialog.

Comment 3

14 years ago
Temporary workaround:

1.  type "about:config" into the address bar
2.  find and set the following preferences to "true"
   a.  security.ssl3.rsa_null_md5
   b.  security.ssl3.rsa_null_sha

Comment 4

14 years ago
this doesn't make sense.

dave.vanderson@cox.net: based on a reading of that page, i'm fairly sure they
wanted him to set those to false, not true.

Comment 5

14 years ago
I should have qualified it - the workaround worked for me.  Before that I got
nondeterministic behavior out of the site.  Every time I went I got through a
different number of pages before getting the redirect to the encryption page.

I don't really know anything about the actual config options.  I thought from
the names that setting them to true would disable those encryption options.  If
that is not what they do that I am baffled.

Has this worked for anyone else?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.