onChange event in select is not called if change made with keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Ricardo Almeida, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When visiting a page that uses onChange event in a selection list, the event is
not fired if the change is made using keyboard (tab until selection list has
focus, then up/down).

Reproducible: Always

Steps to Reproduce:
1. Open a web page that uses onChange event in a selection list (don't have any
URL it's a private intranet application)
2. Press tab until select list has focus
3. Change the option using up/down

Actual Results:  
onChange isn't fired

Expected Results:  
should call associated javascript code
(Reporter)

Comment 1

13 years ago
Created attachment 173078 [details]
Selection box that should trigger a simple alert

Simple 2 options list that trigger an alert message. When changing option with
the keyboard onChange isn't triggered...
(Reporter)

Comment 2

13 years ago
This is probably an issue with Mozilla suite, but I only have firefox installed
so I can't try it...

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.