Last Comment Bug 280827 - Preferences toolbar needs help tags (tooltips)
: Preferences toolbar needs help tags (tooltips)
Status: RESOLVED FIXED
: fixed1.8.1, polish
Product: Camino Graveyard
Classification: Graveyard
Component: Preferences (show other bugs)
: unspecified
: PowerPC All
P5 trivial (vote)
: Future
Assigned To: froodian (Ian Leue)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 11:59 PST by louis bennett
Modified: 2006-08-15 08:37 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Adds tooltip support to preferences toolbar (2.93 KB, patch)
2005-10-06 12:55 PDT, Chris Lawson (gone)
no flags Details | Diff | Splinter Review
Uses labelForPane (1.07 KB, patch)
2006-08-10 22:42 PDT, froodian (Ian Leue)
stuart.morgan+bugzilla: review+
mikepinkerton: superreview+
Details | Diff | Splinter Review

Description User image louis bennett 2005-02-02 11:59:33 PST
The preferences toolbar is very useful if it's set to display icon & text.
However, if you toggle its view to icon-only (by command-clicking the toolbar
control thrice), there should still be a help tag for each icon.

Steps to reproduce:
1. Open Preferences
2. Command-click the toolbar control thrice, such that the toolbar is in its
"Icon Only" mode.
3. Hovering over an icon should produce a help tag, but does not.
Comment 1 User image Wevah 2005-04-02 01:50:29 PST
Well, no Apple-supplied applications' preference windows do this...
Comment 2 User image Samuel Sidler (old account; do not CC) 2005-04-02 02:00:32 PST
I agree, no other major Mac OS X apps have this (that I can find). This is a
*very* minor bug and probably won't be closed until way after 1.0. I'm targeting
for future and prioritizing as 5.
Comment 3 User image Chris Lawson (gone) 2005-10-05 15:05:36 PDT
Taking. If I haven't tossed a patch up here within two weeks, someone holler at me.

cl
Comment 4 User image Chris Lawson (gone) 2005-10-06 12:55:09 PDT
Created attachment 198720 [details] [diff] [review]
Adds tooltip support to preferences toolbar

I've basically modified and duplicated the labelForPane method to create
tooltips instead of labels (in a method called, creatively, toolTipForPane).

This falls back on the same sort of backup names as labelForPane does (if it
can't find something in the pref pane called "PreferencePanelToolTip"). Right
now, that means that the History and Downloads prefs panes get labelled with a
really ugly tooltip (org.mozilla.camino.preference.history). I can add proper
tooltips to the various pref panes if someone wants me to.

cl
Comment 5 User image Stuart Morgan 2006-07-01 10:55:58 PDT
Why not just set the tooltip to labelForPane: (or at least use that as the backup case)?
Comment 6 User image froodian (Ian Leue) 2006-08-10 22:42:04 PDT
Created attachment 233202 [details] [diff] [review]
Uses labelForPane

cl, I hope you don't mind me taking this.

This just uses labelForPane, since it works.
Comment 7 User image Stuart Morgan 2006-08-12 19:36:37 PDT
Comment on attachment 233202 [details] [diff] [review]
Uses labelForPane

r=me
Comment 8 User image Mike Pinkerton (not reading bugmail) 2006-08-14 05:38:25 PDT
Comment on attachment 233202 [details] [diff] [review]
Uses labelForPane

sr=pink
Comment 9 User image Mark Mentovai 2006-08-15 08:37:41 PDT
Checked in on the trunk and MOZILLA_1_8_BRANCH.

Note You need to log in before you can comment on or make changes to this bug.