long link shows up as a straight line

RESOLVED DUPLICATE of bug 264405

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 264405
14 years ago
13 years ago

People

(Reporter: miclaes, Unassigned)

Tracking

({qawanted})

Trunk
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Look at the page submitted in the URL field above.

The long link just looks like ___________________________

Reproducible: Always

Steps to Reproduce:
1. Look at the page submitted in the URL field above.
2. ?
3. Profit?

Actual Results:  
The long link just looks like ___________________________

Expected Results:  
Shown the link text properly

Comment 1

14 years ago
WFM in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b)
Gecko/20050130 Firefox/1.0+

Also Firefox 1.0 is out, you might want to upgrade.
Reproducible on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050202
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050202 Firefox/1.0+
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050203
Firefox/1.0+

This is very likely a dupe, can't find it at the moment.
Component: General → Layout
OS: Windows XP → All
Product: Firefox → Core
Hardware: PC → All
Version: unspecified → Trunk

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 177565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
I don't think this is a dupe of that bug. This is not just about the link not
wrapping, it's about it not actually being displayed correctly (ie the text part
disappears). I've seen similar bugs dealing with long lines of text in textboxes
etc, so I'm guessing this is a dupe of something, I just can't find it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

14 years ago
Created attachment 173457 [details]
Reduced Testcase

It seems the missing linktext reappears if you delete: font-family: "Bitstream
Vera Sans", sans-serif; in html, body{} (in http://validator.w3.org/base.css).
Changing it to font-family: monospace or font-family: serif also makes the text
reappear. Bug 92193 could be causing problems too.

Comment 6

14 years ago
(In reply to comment #4)
> I don't think this is a dupe of that bug. This is not just about the link not
> wrapping, it's about it not actually being displayed correctly (ie the text part
> disappears). I've seen similar bugs dealing with long lines of text in textboxes
> etc, so I'm guessing this is a dupe of something, I just can't find it.

Ah ok, on my PC i saw the full link and nothing disappeared (it was just the
wrapping issue). But now that i read Comment 0 again, it's clear to me, too :).
Is this really "all"?  Has it been reproduced on anything but Windows?  It
worksforme on Linux....
(In reply to comment #7)
> Is this really "all"?  Has it been reproduced on anything but Windows?  It
> worksforme on Linux....

See comment 2.
Assignee: firefox → nobody
Keywords: qawanted
QA Contact: general → layout
I think this is a dupe of bug 264405.

Comment 10

13 years ago
As indicated in comment 9, this is a duplicate of bug 264405.  Resolving DUPLICATE.

*** This bug has been marked as a duplicate of 264405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.