If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Stupid web site runs a loop

VERIFIED DUPLICATE of bug 61098

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 61098
13 years ago
10 years ago

People

(Reporter: Mirko, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041128 Firefox/1.0 (Debian package 1.0-4)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041128 Firefox/1.0

Visiting this page with javascript enabled make firefox crashes (need to kill
it) some other Polish blog uses this "trick"

Here's the code.
"script language="JavaScript"
haslo=prompt("Wpisz has?o dost?pu ;d","");
while(haslo!="pyruryru"){
alert("Eee i co? ?yso Ci? :P Jak nie wiesz to dawaj na nr gg: #1435300")
haslo=prompt("Sexi error :P","");
}
/script"

Reproducible: Always

Steps to Reproduce:
1.Visiting the above page vith javascript active
2.
3.

Actual Results:  
Firefox crashes

Expected Results:  
Maybe an alert and a feature that prevent this script to be executed

Comment 1

13 years ago
note that if you're using a browser with a javascript debugger, you can stop this.
debug>[x] exclude browser files
while the silly alert is up, click stop in the debugger
click ok/cancel in the alert
in the immediate window of venkman, enter:
alert=function (){throw "stop that"}
click continue
your problem is gone.
Summary: Firefox crashes due to javascript while loop with operand not equals (!=) → Stupid web site runs a loop
Whiteboard: DUPEME
(Reporter)

Comment 2

13 years ago
We should think to normal people.
They don't know what's a while loop as they don't know what's a js debugger.
This process should be automated by browser I think,because people won't trouble
but something that works in the easiest way not all people are pleased to spent
time on the net to solve software related problem.

*** This bug has been marked as a duplicate of 61098 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.