Closed Bug 281176 Opened 15 years ago Closed 14 years ago

rename bugzilla components "Base" and "Sunbird and Calendar-Extension Front End"

Categories

(Calendar :: General, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 339020

People

(Reporter: gekacheka, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

  Problem: "Sunbird and Calendar-Extension Front End"
    is appropriate for many bugs by Calendar bug submitters,
    but "Base" is frequently chosen instead.


Reproducible: Always

Steps to Reproduce:
1. https://bugzilla.mozilla.org/enter_bug.cgi?product=Calendar&format=guided
2. Try to select a Component for a display problem


Actual Results:  
"Base" is visible, and when you click on it, its description includes the word
"interface".
"Sunbird and Calendar-Extension Front-end" is invisible (requires scroll) and
way down at the bottom, and when you click on it, it doesn't say anything about
the display.

Expected Results:  
The component(s) for display behavior (user interface) problems are the most
common reported by users, so they should be obvious in the first few elements,
so users can easily pick the right one.


  Currently the description for "Base" is
      "For bugs in the core interfaces and components of the calendar
       module (calendar/base/*)."
    For users, "interface" can mean "User Interface", so this sounds
    better than anything else in the first few elements.

  Suggestion: avoid using the word "interface" in component descriptions that
  are not for the user interface.

  Currently the description for "Sunbird and Calendar-Extension Front End" is 
       "For issues with the chrome, JavaScript, locale info and skin
       code which make up the Calendar front end (Sunbird and
       Sunbird-like extensions for the Suite, Thunderbird and Firefox).
    For novice users, there is nothing here that suggests the user
    interface.  (What's a front-end? is it like the front-end of a car,
    which includes the engine and steering?)  It is way down at the end of 
    the list scrolled off the bottom of the list, so most users probably
    do not see it.

  Suggestion: use a name that appears near or at the top.
  Suggestion: make description clearer for people not familiar with the code.
  Suggestion: "Sunbird and Calendar-Extension" applies
    not just to this component, so drop them from name of component.
Possible improvement:

old: Base
        For bugs in the core *interfaces and* components of the calendar
        module (calendar/base/*).

new: *Core Internal Data Components* 
	For bugs in the core *internal data* components of the calendar
	module (calendar/*core*/).

Adds "internal data" to make clear that this module is 
not about the visible display, nor the data files.

(Minor suggestion: use "core" instead of "base" ---
 a "base" type is used to create "derived" types, 
 but the types defined here are not extended by derived types in use.)
We can certainly rename "Base" to "Core" if people really think it'll make a
difference; I'm skeptical.  We're not renaming the directory, for all sorts of
reasons.
Possible improvement:

old: Sunbird and Calendar-Extension Front-End
        For issues with the chrome, JavaScript, locale info, and skin
        code which make up the Calendar front end (Sunbird and
        Sunbird-like extensions for the Suite, Thunderbird, and Firefox).
new: *Display and Controls*
        For issues with *display and control behavior*
        (/content/ XUL and JavaScript, /skin/ CSS spacing and images, 
         and /locale/ text DTDs and properties).

('Display' will appear listed near the top, while 'User Interface' would appear
at the bottom and would require scrolling, so 'Display' is preferred.)
QA Contact: gurganbl → general
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

*** This bug has been marked as a duplicate of 339020 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.