Images don't center and the in and out fading don't work.

RESOLVED DUPLICATE of bug 242609

Status

()

RESOLVED DUPLICATE of bug 242609
14 years ago
14 years ago

People

(Reporter: rudymens, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.5) Gecko/20041202 Firefox/1.0

In the popup's at http://www.noramens.nl/port ( pick a subject there for the 
popup)the images don't center. Mozilla shows the images almost from the center 
to the left and outside the borders. So you sometimes if the image is to big, 
you don't see the hole image. Also the fade in and fade don't work at all. I 
don't see an error or message, only that it don't work. I'am the designer of 
the website and I use a javascript to fade the images in and out. (I have put 
the javascipt by additional information) I didn't discover any problem with 
Internet Explorer.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.noramens.nl/port.htm
2.Click on "boten"
3.A popup comes up and move you mouse over one of the images



Actual Results:  
Images are not centerd, the fade didn't work

Expected Results:  
Center the images and fade the images in and out. 

<script language="JavaScript" type="text/javascript">
// hier definieer je alle afbeeldingen
var afbeeldingen=new Array()
afbeeldingen[0]=["Schilderijen/pioenrozen.jpg", "#"] // "pad en naam van de 
foto", "eventuele hyperlink"
afbeeldingen[1]=["Schilderijen/herfstbladeren.jpg", "#"]


var voorladen="ja" // "ja" of "nee"
var optlinktarget="" // optioneel: hier kun je een target invullen bij 
framesgebruik
var beeldrandbreedte=0
var filterstring="progid:DXImageTransform.Microsoft.GradientWipe
(GradientSize=1.0 Duration=0.7)"

// hieronder niets wijzigen

if (voorladen=="ja"){
for (x=0; x<afbeeldingen.length; x++){
var ditbeeldje=new Image()
ditbeeldje.src=afbeeldingen[x][0]}}

function beeldcode(dezeafbeelding){
var beeldhtml=""
if (dezeafbeelding[1]!="")
beeldhtml='<a href="'+dezeafbeelding[1]+'" target="'+optlinktarget+'">'
beeldhtml+='<img src="'+dezeafbeelding[0]+'" border="'+beeldrandbreedte+'">'
if (dezeafbeelding[1]!="")
beeldhtml+='</a>'
return beeldhtml}

function wijzigbeeld(beeldplaatsing, beeldindex){
if (document.getElementById){
var imgobj=document.getElementById(beeldplaatsing)
if (imgobj.filters && window.createPopup){
imgobj.style.filter=filterstring
imgobj.filters[0].Apply()}
imgobj.innerHTML=beeldcode(afbeeldingen[beeldindex])
if (imgobj.filters && window.createPopup)
imgobj.filters[0].Play()
return false}}
</script>
Notice the "Microsoft" in "DXImageTransform.Microsoft"? That means that you are
using Internet Explorer proprietary techniques that don't work in Firefox.

*** This bug has been marked as a duplicate of 242609 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.