Keeping Backspace pushed down when the history contains more than 2 entries occasionally causes a crash [@ nsView::SetVisibility]

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: roc)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050206 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050206 Firefox/1.0+

Pushing Backspace while loading a page occasionally causes a crash.

Incident ID: 3538552

Source File, Line No.
c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp, line 467
Stack Trace 	
nsView::SetVisibility 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 467]
nsIFrame::AreAncestorViewsVisible 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrame.cpp,
line 2444]
nsIFrame::GetScreenRect 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrame.cpp,
line 2322]
nsFrame::CheckInvalidateSizeChange 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrame.cpp,
line 2590]
SortByZOrder 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1182]
nsViewManager::UpdateWidgetArea 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1774]
nsView::ResetWidgetBounds 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 398]
nsWindow::CaptureRollupEvents 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1182]
nsWindow::OnKeyDown 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 3106]
nsWindow::ConstrainZLevel 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 3288]
nsWindow::ProcessMessage 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 3827]
nsWindow::StandardWindowCreate 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1500]
USER32.dll + 0x8709 (0x77cf8709)
USER32.dll + 0x87eb (0x77cf87eb)
USER32.dll + 0x89a5 (0x77cf89a5)
USER32.dll + 0x89e8 (0x77cf89e8)
CallOpenSaveFileNameA 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsToolkit.cpp,
line 312]
nsAutoCompleteController::QueryInterface
main 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 60]
kernel32.dll + 0x16d4f (0x7c816d4f)

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
see bug 281330 too
Keywords: crash
Summary: Crash at nsView::SetVisibility → Pushing Backspace while loading a page occasionally causes a crash [@ nsView::SetVisibility]
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
Bug 281614 occurs at nsView::SetOpacity
(Reporter)

Updated

13 years ago
Component: General → Layout: View Rendering
Product: Firefox → Core
(Reporter)

Updated

13 years ago
Blocks: 281614
(Reporter)

Comment 3

13 years ago
Editing the summary. The reproduciblity of this bug seems higher when the
history contains more than 2 entries and you are rapidly going back.
Summary: Pushing Backspace while loading a page occasionally causes a crash [@ nsView::SetVisibility] → Keeping Backspace pushed down when the history contains more than 2 entries occasionally causes a crash [@ nsView::SetVisibility]
(Reporter)

Updated

13 years ago
Blocks: 281891
Reassigning for real.

It looks like all the crashes involved have to do with deleted objects being
accessed for some reason....
Assignee: firefox → roc
QA Contact: general → ian
Could be fixed by the patch in bug 281424.  Please retest in tomorrow's build?
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsView::SetVisibility]
You need to log in before you can comment on or make changes to this bug.