change 'network.enableIDN' to false has no effect after closing and reopening Firefox

VERIFIED DUPLICATE of bug 281365

Status

Toolkit Graveyard
Error Console
--
major
VERIFIED DUPLICATE of bug 281365
13 years ago
a year ago

People

(Reporter: Mel Brown, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

At http://www.netsquirrel.com/articles/mozilla_spoofing.html, click on the
paypal.com link. The demo Javascript code spoofs the URL and sends you to his
page that displays simply "meeow." Use about:config to set 'network.enableIDN to
false, and Firefox no longer falls for that trick. 

Now exit all Firefox tasks and start Firefox again. You can use about:config to
verify that the value is still set to false, but go back to the above site and
click on the paypal.com link once again. You'll get the "meeow" screen again.
Not good. 

Reproducible: Always

Steps to Reproduce:
1. At http://www.netsquirrel.com/articles/mozilla_spoofing.html, click on the
paypal.com link. 
2. The demo Javascript code spoofs the URL and sends you to his page that
displays simply "meeow."
3. Use about:config to set 'network.enableIDN to false, and Firefox no longer
falls for that trick. 
4. Now exit all Firefox tasks and start Firefox again. You can use about:config
to verify that the value is still set to false. 
5. Go back to the above site and click on the paypal.com link once again. 
6. You'll get the "meeow" screen again. Not good. 

Actual Results:  
Firefox fails to remember the value of 'network.enableIDN' even though
about:config shows it properly set to false.

Expected Results:  
Firefox should not have gone to the "meeow" URL.

I tried creating a user.js file in C:\Documents and
Settings\<username>\Application Data\Mozilla\Firefox\Profiles with a command to
set the value to false, but Firefox never even accessed the user.js file. I
determined that fact by using Windows Explorer with the Date Accessed column
enabled.

Comment 1

13 years ago
is already fixed, update to the current branch nightlies (builds after
2005020719 have the fix)

Firefox 1.0.1 Builds
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1/

Mozilla 1.7.6 Builds
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/



*** This bug has been marked as a duplicate of 281365 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.