[gtk2] Drop down lists do not open immediatly with certain CSS configuration

RESOLVED FIXED in mozilla1.8.1beta2

Status

Core Graveyard
GFX: Gtk
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Thomas Petazzoni, Assigned: Robin Lu)

Tracking

({fixed1.8.1})

Trunk
mozilla1.8.1beta2
x86
Linux
fixed1.8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

756 bytes, text/html
Details
736 bytes, patch
Brian Ryner (not reading)
: review+
Mike Schroepfer
: approval1.8.1+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.5) Gecko/20050206 Firefox/1.0 (Debian package 1.0+dfsg.1-5)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.5) Gecko/20050206 Firefox/1.0 (Debian package 1.0+dfsg.1-5)

Inside a form, if you put a "select" with some options, and then apply a
":focus" CSS class, there are certain conditions for which you have to click 3
times on the drop down list to open it, instead of one time.

If the :focus CSS class contains :
 - background-color + border + color : PROBLEM
 - background-color + color : PROBLEM
 - border + color : PROBLEM
 - color : no problem

Reproducible: Always

Steps to Reproduce:
1. Use the following HTML file (W3 validated)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html>
<head>
    <title>Title</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-15"/>
    <link rel="stylesheet" type="text/css" href="test.css" />
</head>

<body>

<form action="plop.html" method="post">
 <p>Select:
 <select class="formulaire">
  <option value="3">Allemand</option>
  <option value="2">Anglais</option>
  <option value="7">Basque</option>
 </select>
 </p>
</form>

</body>
</html>

2. Use the following CSS (W3 validated)

.formulaire {
    border: solid 1px black;
    font-size: 12px;
    background-color: #fffbf7;
    color: #000000;
}
.formulaire:focus{
    background-color: #eeeae6;
    border: 1px solid #777;
    color: #000000;
}

3. Load the page in your browser

4. Click on the drop down list. Three clicks are necessary to open it.

Actual Results:  
With some CSS attributes, drop down lists require 3 clicks to open.

Expected Results:  
Whather the CSS attributes are, drop down lists should open in only one click.

Comment 1

13 years ago
Created attachment 173789 [details]
Reporters testcase

WFM :Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050205
Firefox/1.0+

Comment 2

13 years ago
The drop-down named "Revues" has to be clicked three times to show the list of
itmes : http://www.persee.fr/
(Reporter)

Comment 3

13 years ago
Here, with Firefox 1.0 under GNU/Linux, the drop-down list at www.persee.fr
works with just one click.
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

13 years ago
This is a bug quite similar with bug 241187. However, the patch in 241187 only
fixed part of the problem. I found it is hard to cache the visibility status
when the nsWindow represents a toplevel window.
(Assignee)

Comment 5

13 years ago
Created attachment 176682 [details] [diff] [review]
patch

read the real visibility status when the nsWindow is a toplevel
Attachment #176682 - Flags: review?(bryner)
Attachment #176682 - Flags: review?(bryner) → review+
(Assignee)

Updated

13 years ago
Attachment #176682 - Flags: superreview?(blizzard)
(Assignee)

Updated

13 years ago
Attachment #176682 - Flags: superreview?(blizzard) → superreview?(firefox)
blizzard@mozilla.org would probably be a better choice for sr, Blake hasn't been
actively reviewing lately.
(Assignee)

Comment 7

13 years ago
I have requested sr from blizzard for several weeks and even sent mail directly
to him but got no response. Anyone else I can seek sr from?
(In reply to comment #7)
> I have requested sr from blizzard for several weeks and even sent mail directly
> to him but got no response. Anyone else I can seek sr from?

brendan@mozilla.org, dveditz@cruzio.com, and scc@mozilla.org are listed as
catch-alls, and for a small patch that already has r=bryner they should be
willing to help you out.

Finding one of these people on IRC and asking about it will probably increase
your chances of getting sr.
(Assignee)

Updated

13 years ago
Attachment #176682 - Flags: superreview?(firefox) → superreview?(dveditz)
(Assignee)

Updated

13 years ago
Blocks: 149981

Comment 9

13 years ago
Also related: bug 154670. 
(Assignee)

Updated

13 years ago
Assignee: firefox → robin.lu

Updated

13 years ago
Blocks: 154670

Comment 10

13 years ago
I'm Observing this Problem only with Unix Clients:

Debian Linux (i386): 
- Firefox 1.0.3
SuSE Linux:
- Firefox 1.0
Solaris (i386): 
- Mozilla 1.7
- Firefox 1.0.4

Under Windoes there isn't any Problem.
(Assignee)

Comment 11

13 years ago
because it is a gtk2 only bug.

I have requested sr for two monthes. I do appreciate if someone can help on
super-reivewing the patch. Thanks in advance.

Updated

13 years ago
Component: General → GFX: Gtk
Flags: review+
Product: Firefox → Core
Summary: Drop down lists do not open immediatly with certain CSS configuration → [gtk2] Drop down lists do not open immediatly with certain CSS configuration
Version: unspecified → Trunk
Attachment #176682 - Flags: review+

Comment 12

12 years ago
Robin's patch fixed all of the three bugs that this one blocks. It'd be great to get this patch in.
Blocks: 163503

Updated

12 years ago
Attachment #176682 - Flags: superreview?(dveditz) → superreview?(roc)
(Reporter)

Comment 13

12 years ago
FWIW, I can't reproduce this bug anymore with Firefox 1.5 on Debian sid.
Attachment #176682 - Flags: superreview?(roc) → superreview+

Comment 14

12 years ago
Patch checked in by timeless.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 15

12 years ago
*** Bug 317306 has been marked as a duplicate of this bug. ***

Comment 16

12 years ago
*** Bug 248910 has been marked as a duplicate of this bug. ***

Comment 17

12 years ago
*** Bug 280434 has been marked as a duplicate of this bug. ***
Doesn't GTK1 need the same fix?
Comment on attachment 176682 [details] [diff] [review]
patch

Is this a branch-suitable patch?  Focus issues suck.
Attachment #176682 - Flags: approval-branch-1.8.1?(bryner)

Updated

12 years ago
Attachment #176682 - Flags: approval-branch-1.8.1?(bryner) → approval1.8.1?

Updated

12 years ago
Attachment #176682 - Flags: approval1.8.1? → approval1.8.1+
mozilla/widget/src/gtk2/nsWindow.cpp 	1.145.2.5
Keywords: fixed1.8.1
Target Milestone: --- → mozilla1.8.1beta2
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.