crash loading hyatt's weblog [@ nsWindow::SetZIndex]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: dbaron, Assigned: blizzard)

Tracking

({crash, regression, testcase})

Trunk
x86
Linux
crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments, 1 obsolete attachment)

I crash loading http://weblogs.mozillazine.org/hyatt/

#5  <signal handler called>
#6  0x04ad6f97 in nsWindow::SetZIndex (this=0x8f4c0a8, aZIndex=100)
    at /builds/trunk/mozilla/widget/src/gtk2/nsWindow.cpp:551
#7  0x01527563 in UpdateNativeWidgetZIndexes (aView=0x8fa9778, aZIndex=100)
    at /builds/trunk/mozilla/view/src/nsView.cpp:574
#8  0x01527889 in nsIView::CreateWidget (this=0x8fa9778,
    aWindowIID=@0x16e1010, aWidgetInitData=0xbff0832c, aNative=0x0,
    aEnableDragDrop=1, aResetVisibility=1, aContentType=eContentTypeInherit)
    at /builds/trunk/mozilla/view/src/nsView.cpp:657
#9  0x011b7a69 in nsHTMLContainerFrame::CreateViewForFrame (aFrame=0x8fca08c,
    aContentParentFrame=0x8fc9e58, aForce=0)
    at /builds/trunk/mozilla/layout/generic/nsHTMLContainerFrame.cpp:584
#10 0x01110325 in nsCSSFrameConstructor::ConstructBlock (this=0x8f739d0,
    aPresShell=0x8f79040, aPresContext=0x8f74390, aState=@0xbff087ac,
    aDisplay=0x902152c, aContent=0x8fcbe60, aParentFrame=0x8fa7b0c,
    aContentParentFrame=0x8fc9e58, aStyleContext=0x902017c,
    aNewFrame=0xbff08554, aFrameItems=@0xbff0878c, aAbsPosContainer=1)
    at /builds/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp:12905
#11 0x01102a3f in nsCSSFrameConstructor::ConstructFrameByDisplayType (
    this=0x8f739d0, aPresShell=0x8f79040, aPresContext=0x8f74390,
    aState=@0xbff087ac, aDisplay=0x902152c, aContent=0x8fcbe60,
    aNameSpaceID=0, aTag=0x86fc9a8, aParentFrame=0x8fc9e58,
    aStyleContext=0x902017c, aFrameItems=@0xbff0878c, aHasPseudoParent=0)
    at /builds/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp:6556
(More stack frames follow...)
(gdb) frame 6
#6  0x04ad6f97 in nsWindow::SetZIndex (this=0x8f4c0a8, aZIndex=100)
    at /builds/trunk/mozilla/widget/src/gtk2/nsWindow.cpp:551
551                 gdk_window_lower(w->mDrawingarea->clip_window);
(gdb) p w
$3 = (nsWindow *) 0x8fe2430
(gdb) p w->mDrawingarea
$4 = (MozDrawingarea *) 0x0
Created attachment 173913 [details]
partly simplified testcase
Created attachment 173915 [details]
simplified testcase
Attachment #173913 - Attachment is obsolete: true

Comment 3

14 years ago
Regression window: 2005-01-25-02 -- 2005-01-28-02  (bug 261238?)
Seems to be GTK2 only.
Keywords: regression, testcase
Created attachment 173927 [details] [diff] [review]
bulletproof GTK2 SetZIndex
Attachment #173927 - Flags: superreview?(blizzard)
Attachment #173927 - Flags: review?(blizzard)
(Assignee)

Comment 5

14 years ago
Comment on attachment 173927 [details] [diff] [review]
bulletproof GTK2 SetZIndex

>+        if (mDrawingarea) {
>+            gdk_window_raise(mDrawingarea->clip_window);
>+        }

Extra braces here (I never use braces with one line unless it's an else and the
if had braces, too.)
Attachment #173927 - Flags: superreview?(blizzard)
Attachment #173927 - Flags: superreview-
Attachment #173927 - Flags: review?(blizzard)
Attachment #173927 - Flags: review-
(Assignee)

Comment 6

14 years ago
Oh, but if you fix that it's r/sr+ on the patch.  No need to ping me again.
Comment on attachment 173927 [details] [diff] [review]
bulletproof GTK2 SetZIndex

I'll make those brace changes.

Requesting 1.8b approval --- this is a recent crash regression and the fix is
extremely low risk
Attachment #173927 - Flags: superreview-
Attachment #173927 - Flags: superreview+
Attachment #173927 - Flags: review-
Attachment #173927 - Flags: review+
Attachment #173927 - Flags: approval1.8b?
Attachment #173927 - Flags: approval1.8b? → approval1.8b+
checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Severity: normal → critical

Comment 9

10 years ago
view/crashtests/281743-1.html
http://hg.mozilla.org/mozilla-central/rev/b0337b6287f3
Flags: in-testsuite+
Crash Signature: [@ nsWindow::SetZIndex]
You need to log in before you can comment on or make changes to this bug.