[IMAP] mozilla mail chokes on Sun SIMS 2.0 IMAP server

VERIFIED WORKSFORME

Status

MailNews Core
Networking
P3
critical
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: dhouston, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Whenever I try to get mail from our IMAP server, a Sun SS20 running Solaris 2.5
and SIMS 2.0, Mozilla goes in to what appears to be an infinite loop.

I've tried this on Solaris 7, Red hat 6.1, and NT 4.

If you need any more information, let me know. I can try whatever oyu might
need.

dale

Comment 1

19 years ago
Hi.  Thanks for reporting this.  Here are some questions which would help us:

1. What build are you using?
2. Does it work correctly on Netscape 4.x?
3. What exactly happens when Mozilla goes into the "infinite loop"? Can you get
out of it by hitting the STOP button?  Or do you have to kill Mozilla?

(add the answers to the bug, please)

CC: jefft
Severity: normal → critical
Summary: mozilla mail chokes on Sun SIMS 2.0 → [IMAP] mozilla mail chokes on Sun SIMS 2.0 IMAP server
(Reporter)

Comment 2

19 years ago
+ ------- Additional Comments From zach@math.berkeley.edu  2000-02-17 09:46
-------
+ Hi.  Thanks for reporting this.  Here are some questions which would help us:
+ 
+ 1. What build are you using?

M13 - just the straight M13 not one of the nightly builds under Solaris 7, NT 4,
and Red Hat 6.1.

+ 2. Does it work correctly on Netscape 4.x?

Yes, on all 3 platforms. Also Pine and Dtmail can access the SIMS IMAP server.

+ 3. What exactly happens when Mozilla goes into the "infinite loop"? Can you
get
+ out of it by hitting the STOP button?  Or do you have to kill Mozilla?

I have to kill Mozilla. The screens stop refreshing and Mozilla will not respond
to any commands. I either need to control-C in the command window that started
it or kill the process manually. 

Comment 3

19 years ago
Sounds bad.  I think it wouldn't hurt to get an IMAP log.  You can get a log by
setting the following environment variables before you start Mozilla:

setenv NSPR_LOG_FILE ~/tmp/imapio.txt
setenv NSPR_LOG_MODULES IMAP:5

You can then attach the log file using the "Create a new attachment" link on the
Bugzilla page. (Make sure no personal info is contained in the file).

Do you see any error messages in the console?
OS: Solaris → All
Hardware: Sun → All
(Reporter)

Comment 4

19 years ago
Created attachment 5364 [details]
imap log file
(Reporter)

Comment 5

19 years ago
I attached the imapio.txt as requested. The file grew to its present size
rapidly and then stopped being written to as Mozilla hung. This is from my
Solaris box, I do not have acces to Mozilla/Solaris at the moment but I could
switch if it would help.

The last few lines from the console, after this I ctrl-C to stop Mozilla:

imap://dhouston@mailhost/INBOX
In ChangeFolderByURI
title string = [INBOX on biostats - Mozilla]
got a request
title string = [Mozilla]
Document: Done (0.725 secs)
WEBSHELL+ = 8
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 9
WEBSHELL+ = 10
commonDialogOnLoad 
title string = [Enter your password]
WEBSHELL- = 9
Move window by 0,20
screen x -1screen y -1
WEBSHELL- = 8
WEBSHELL- = 7

/home/dhouston/mozilla/package rasch.bio.ri.ccf.org> 

Comment 6

19 years ago
What version of mozilla you were running? The 

3076[86e0510]: mailhost:A:CreateNewLineFromSocket: * LSUB () "/" mail/

looks troublesome, but I believe that I have fixed the hanging problem. Could 
you try the most recent build? Thanks,
(Reporter)

Comment 7

19 years ago
The most recent build fixes the problem, at least on Linux. Thanks!!

I will give the latest Solaris build a shot but if you do not hear from me it
must be fixed.

Once again, thanks, you guys rule.

Comment 8

19 years ago
Once you've made sure it works on Solaris, can you resolve the bug and mark it
WORKSFORME? Thanks.
(Reporter)

Comment 9

19 years ago
I downloaded the latest Solaris build (2-17 around 5 pm) and it is not running
for me. When I truss mozilla-bin I see the following:

lwp_sema_wait(0xFC5F1E78)       (sleeping...)
door_return(0x00000000, 0, 0x00000000, 0) (sleeping...)
poll(0xFC611BE0, 1, 35000)                      = 0
poll(0x00164AC8, 3, -1)         (sleeping...)
signotifywait()                 (sleeping...)
poll(0xFC611BE0, 1, 35000)      (sleeping...)
lwp_sema_wait(0xFC5F1E78)

I tried the set shmsys:shminfo_shmseg = 10 trick in /etc/system and also the
latest kernel (106541-09) and the latest libthread patch (106980-09) but to no
avail. I'm running Solaris 7 on UltraSPARC and M13 worked on this machine. Do
you want me to file this as a separate bug and then get back to the mail bug
when the latest build works?

Comment 10

19 years ago
Yes, a separate bug would be good.  You can also post in
netscape.public.mozilla.builds

Updated

19 years ago
Depends on: 26035

Comment 11

19 years ago
dhouston, have you had a chance to look at it with a Solaris build yet?
(Reporter)

Comment 12

19 years ago
I still need a version of Mozilla that will run under Solaris 7. I try and
download the nightly builds every day or so but so far they all choke as in bug
26035.

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

18 years ago
[richb - 4/23/00]
We (Sun) have made a version of Mozilla-beta1 available in binary format
(complete with gtk+ and glib) libraries from www.sunfreeware.com. Could you
see if the bug has been fixed against this version?

Comment 14

18 years ago
Should this be closed WFM now?

Comment 15

18 years ago
any update dhouston?
(Reporter)

Comment 16

18 years ago
it works!

Comment 17

18 years ago
Cool! Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
super. Will mark verified per dhouston's comments.  We're going to MailConnect 6 
in a few weeks and will also test out the SIMS server.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.