Closed Bug 282527 Opened 20 years ago Closed 20 years ago

certutil -C changes -8 (dns alt name ext) option to -7 (email ext)

Categories

(NSS :: Tools, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil.williams, Assigned: wtc)

Details

Attachments

(1 file)

Attempting to add a DNS alt name extension yields a cert with an extension with
type RFC822Name which is in error. I believe this behavior is explained by the
following 2 lines in AddSubjectAltNames() in nss/cmd/certutil.c

1733         current->type = type;
1734         current->type = certRFC822Name;
Good catch, Neil.  Obviously, one of those
two lines is wrong.  I think the second line
should be removed.
This bug was in Bob Relyea's first
implementation of the feature (bug 122863).
In hindsignt it's obvious that the new
line

    current->type = type;

was intended to replace the old line

    current->type = certRFC822Name;
Version: unspecified → 3.8
Attached patch Proposed patchSplinter Review
Attachment #175219 - Flags: superreview?(rrelyea)
Attachment #175219 - Flags: review?(neil.williams)
(In reply to comment #3)
> Created an attachment (id=175219) [edit]
> Proposed patch
> 

Reviewed the proposed patch. It does the trick.
Thanks, Neil.  I checked in the patch on
the trunk for NSS 3.10.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.10
Attachment #175219 - Flags: review?(neil.williams) → review+
Setting priorities on unprioritized bugs resolved fixed for NSS 3.10.
Priority: -- → P2
Comment on attachment 175219 [details] [diff] [review]
Proposed patch

r+ relyea
Attachment #175219 - Flags: superreview?(rrelyea) → superreview+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: