Closed Bug 282726 Opened 17 years ago Closed 17 years ago

Table cell <td> bgcolor attribute displays incorrectly when set to "transparent"

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 227072

People

(Reporter: matthew, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

<html>
<body bgcolor='gray'>
<table><tr><td onmouseover='this.bgColor="#d0e8ff";'
onmouseout='this.bgColor="transparent";'><big>&nbsp;&nbsp;H E L L
O&nbsp;&nbsp;</big></td></tr></table>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
1.Save the above code as an HTML file
2.Place it in HTDOCS
3.Browse to it in Firefox
4.Move your mouse pointer over the table cell that contains the text "HELLO"
5.Move your mouse pointer away from that table cell

Actual Results:  
Instead of the table cell returning to its transparent state, it was displayed
with a dark-blue background.

Expected Results:  
The table cell should get a transparent background again (its default state).
Work-around: change bgcolor to "" (empty-string) instead of "transparent" (which
works in I.E.)
Severity: normal → minor

*** This bug has been marked as a duplicate of 227072 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.