Margin on input[type="image"] breaks layout in Camino (fix form css)

VERIFIED FIXED in Camino1.0

Status

Camino Graveyard
HTML Form Controls
P3
normal
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Mark Leverson, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

({fixed1.8.0.1, fixed1.8.1})

unspecified
Camino1.0
PowerPC
Mac OS X
fixed1.8.0.1, fixed1.8.1
Bug Flags:
camino1.0 +

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041201 Camino/0.8.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041201 Camino/0.8.2

The login box on by banks online baking service doesn't display the way it
should. This doesn't occur with Mozilla 1.7.5. I originally thought that this
was just a badly coded page but since Mozilla displays it properly, there may be
another cause.

Reproducible: Always

Steps to Reproduce:
1.Go to https://www.fpcuonline.org/onlineserv/HB/Signon.cgi
2.
3.

Actual Results:  
The page displayed a box without all the edges of the box lines up properly.

Expected Results:  
Displayed the page the way that Mozilla 1.7.5 does.

Updated

13 years ago
Component: General → History: Global
Product: Camino → Core
Version: unspecified → Trunk
(Reporter)

Comment 1

13 years ago
Since the Product has been changed to Core for this bug, it isn't as clear as it
once was, so I will restate it.

Camino doesn't display the login box on by banks online baking service the way
it should. It is displayed correctly by both Mozilla 1.7.5 and FireFox 1.0.
(Reporter)

Comment 2

13 years ago
This brings up a question. Why is this bug listed as a Core, History:Global,
issue? It only involves Camino, not Mozilla or FireFox.
Back to Camino to look into; this is clearly not a global history bug.
Component: History: Global → General
Product: Core → Camino
Version: Trunk → unspecified
Created attachment 178593 [details]
Screenshot of bad behavior

Attaching a screenshot of the unexpected behavior and verifying.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
Adding
margin: 0;
to input[type="image"] in forms.css fixes the bug.

Comment 6

13 years ago
Indeed I notice a similar problem on my school's web page:
http://www.cmu.edu/
Where the bottom of the page doesn't align, like the bank login box.
Again, only occurs in Camino.

Comment 7

13 years ago
Although the intial page loads and I can imput the account and passswd info,
clicking the login tab does nothing. Sems to have started for me with yesterdays
nightly build.

URL: https://onlinebanking-nw.bankofamerica.com/login.jsp?MSIE=True&statecheck=WA

Comment 8

13 years ago
Note comment 5.
Assignee: pinkerton → sfraser_bugs
Priority: -- → P3
Summary: My banking login page doesn't display properly → My banking login page doesn't display properly (fix form css)
Target Milestone: --- → Camino1.0
(Reporter)

Comment 9

13 years ago
My bank has changed it's Login page and this bug is no longer reproducable at
it's site.

Comment 10

13 years ago
(In reply to comment #9)
> My bank has changed it's Login page and this bug is no longer reproducable at
> it's site.

That's why we need test cases attached to bugs.
Created attachment 192222 [details]
Testcase (I hope)

Hopefully this will do; it's a little bit of http://www.cmu.edu  Layout
testcases are not my strong suit.

If not, someone go grab the entire http://www.cmu.edu page :-)
Component: General → HTML Form Controls
Summary: My banking login page doesn't display properly (fix form css) → Margin on input[type="image"] breaks layout in Camino (fix form css)

Comment 12

12 years ago
Created attachment 200854 [details]
Testcase v2 (Reduced)

A simpler testcase with a check

Comment 13

12 years ago
Created attachment 200855 [details]
This is what testcase v2 looks like with Firefox (and Safari equally)
It's not this bug (but a cousin), but there have been a couple of threads in the forum recently about the search box on the trailers page at Apple.  It's similarly broken by our forms css (I think in that case it's on the text input), but I haven't had time to reduce it to even "Testcase (I hope)" level.

http://forums.mozillazine.org/viewtopic.php?t=329382

Updated

12 years ago
Flags: camino1.0+
Depends on: 315203

Updated

12 years ago
Assignee: sfraser_bugs → alqahira

Comment 15

12 years ago
Fixed by bug 315203 checkin.

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Keywords: fixed1.8.0.1, fixed1.8.1

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.