Bookmarks deleted following XP blue screen

RESOLVED DUPLICATE of bug 193749

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 193749
13 years ago
12 years ago

People

(Reporter: David Manton-Hall, Unassigned)

Tracking

({dataloss})

1.0 Branch
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

Following a blue screen, all bookmarks have disappeared.
Firefox was running at the time of the crash.  
The XP crash was unrelated (ATI driver issue).
Upon restarting the machine, and firefox all bookmarks had vanished.

Reproducible: Didn't try

Steps to Reproduce:
1. Have a firefox running.
2. Get a crash
3. Restart machine and firefox

Actual Results:  
Bookmarks vanished.

Expected Results:  
Not have lost the bookmarks.

Whilst critical is perhaps overstating the severity, I have lossed all my
bookmarks as a result - which for me (and presumably others) is rather significant.

Comment 1

13 years ago
Adding dataloss keyword, but I can't test myself (wrong OS).

It might help if you're able to make this easier to reproduce--the steps seem
rather general.
Keywords: dataloss
(Reporter)

Comment 2

13 years ago
I am sorry about the lack of reproducability.
Unfortunately (at least in this case) I don't get blue screens that often.
I can't simulate with a power loss as I use a PC and powering off is an orderly
shutdown.

Comment 3

13 years ago
*** Bug 283115 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
(In reply to comment #2)
> ... I use a PC and powering off is an orderly shutdown.

Actually, despite the fact that a shutting down a filesystem and an OS 
should be an orderly process, this kind of dataloss has been seen in
those circumstances. See Bug 193749 "bookmarks and personal preferences are 
lost after system crash due to power failure", its many duplicates and
the advice in http://www.mozilla.org/start/1.5/troubleshooting/

Comment 5

13 years ago
(In reply to comment #4)
> (In reply to comment #2)
> > ... I use a PC and powering off is an orderly shutdown.
> 
> Actually, despite the fact that a shutting down a filesystem and an OS 
> should be an orderly process, ...

See Bug 170539 Comment 30 : Could there be a problem with software that
scans files for some reason?

Comment 6

13 years ago
BSOD -> bug 193749

(In reply to comment #5)
> See Bug 170539 Comment 30 : Could there be a problem with software that
> scans files for some reason?

That vanishes not your bookmarks, only the prefs and mail accounts settings.

*** This bug has been marked as a duplicate of 193749 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.